Input fails to local Phant server

Everything pertaining to the data.sparkfun.com service, the phant project which powers it, and user projects which talk to the service.

Moderators: phalanx, toddtreece, Brennen@SparkFun

Post Reply
around
Posts: 3
Joined: Tue Aug 11, 2009 12:36 pm

Input fails to local Phant server

Post by around » Mon Aug 29, 2016 6:23 pm

I have installed a local Phant server on my Windows 10 machine. I followed the Virtualbox, Vagrant, Git installation instructions.

I can connect to the local server through my browser and telnet. Creation of new streams and review of streams through the browser and telnet work with no issues.

When I try and input data, the browser reports that it cannot connect to the page specified. If I introduce deliberate errors into the input string (wrong or missing keys), then I get the correct error responses. If I omit or introduce incorrect data fields, the browser again reports that it cannot connect to the page specified.

When I try and output stream data, I get the expected no data error responses (not surprising as I cannot input data!!).

I am at a loss as to how to troubleshoot this issue. The server appears to be working for everything except data input. Any ideas on where I should focus my troubleshooting efforts?

Cheers,

Adrian

around
Posts: 3
Joined: Tue Aug 11, 2009 12:36 pm

Re: Input fails to local Phant server

Post by around » Thu Oct 27, 2016 7:16 pm

Problem traced to changes in latest version of NodeJS. See Phant Github page Issue #200

Post Reply