Page 1 of 1

Work Around...Xilinx ISE and Windows 8

Posted: Wed Jul 16, 2014 2:14 pm
by Purple Squirrel
For those of you who already have, are going to, or are going to against your will, migrate to a Windows 8 machine and intend on using the Xilinx ISE tools you are likely to have an issue run the software. At least one if not two of the .exe files you need (either _pn.exe or _xlcm.exe).

I ran into this problem on my new Windows 8 machine and came across this solution in my journey to locate a fix (see attached file). This can be used for 14.6, 14.5, etc..just change the revision number. I havent tried this for versions older than 14.5 so just be forewarned that it may not work for versions older than 14.5

Credit for this goes to Binary Koala.

Get Xilinx ISE 14.7 Webpack to work on Windows 8
Unfortunately for me, and many other Xilinx users, the ISE Design Suite 14.6 Webpack Edition was not supported in Windows 8. Specifically, many users including myself encountered instability in the Xilinx License Manager (xlcm.exe) that made it impossible to validate a Webpack License therefore rendering the ISE tools unusable. I found a workaround that enabled me to bypass this issue with the License Manager and run ISE 14.7 on Windows 8.1. If you too experienced these issues, follow the steps listed below:
1. Navigate to C:\Xilinx\14.7\ISE_DS\ISE\lib\nt64 and search for "libPortability". Search query should return 2 results:
1. libPortability.dll
2. libPortabilityNOSH.dll
2. Rename "libPortability.dll" to "libPortability.dll.orig". Just in case we mess up, we can always revert back to this original.
3. Copy and paste "libPortabilityNOSH.dll" into the same directory. Name the copy "libPortability.dll"
4. Steps 1-3 were enough for some to resolve the issue. However, xlcm.exe was still crashing for me. If you still have errors with xlcm.exe not being able to validate or acquire a license, proceed on.
5. Go to the Start Menu, search for "xilinx". One of the first results should be "Manage Xilinx Licenses". Right click > "Open File Location"
6. Windows Explorer will open the shortcut location to the License Manager. Copy and pate the "Manage Xilinx License" shortcut so a backup is present.
7. Select the original "Manage Xilinx License" shortcut. Right click > "Properties".
8. Highlight the "Target" field, it should read:
o C:\Xilinx\14.7\ISE_DS\settings64.bat C:\Xilinx\14.7\ISE_DS\common\bin\nt64\xlcm.exe -manage
9. Make the following changes
o C:\Xilinx\14.7\ISE_DS\settings32.bat C:\Xilinx\14.7\ISE_DS\common\bin\nt\xlcm.exe -manage
10. Select "OK". Restart the License Manager. It should be work now. Follow the directions to acquire a Webpack License for free or load an existing license file. Hope it helped!

See the attached PDF.
ISE 14.7 on Windows 8.pdf

Re: Work Around...Xilinx ISE and Windows 8

Posted: Thu Jul 17, 2014 5:03 am
by phalanx
Purple Squirrel wrote:I would have attached it but this forum does not allow PDF or Word document attachments
Try it now. I enabled PDF files up to 5MB in the forum settings.


Re: Work Around...Xilinx ISE and Windows 8

Posted: Thu Jul 17, 2014 11:47 am
by Purple Squirrel
PDF added.

Thanks for enabling the PDF downloads phalanx