Voltage regulator on PCB I designed - not working

General project discussion / help
Did you make a robotic coffee pot which implements HTCPCP and decafs unauthorized users? Show it off here!

Moderator: phalanx

Post Reply
robopilot99
Posts: 2
Joined: Wed Dec 27, 2017 3:59 pm

Voltage regulator on PCB I designed - not working

Post by robopilot99 » Wed Dec 27, 2017 4:44 pm

Hello, I am working on building a watch based on a Nokia 5110 display and an ATSAMD21G microprocessor. I have created and ordered a custom PCB from OSH Park but have encountered an issue now that the board is populated. When I connect the board to power, the MIC5219 voltage regulator does not regulate the voltage correctly. When running from the 5V USB socket, the main power (which should be 3.3V) runs at about 1.4V and when the board is connected to the battery (about 3.8V when I was testing) the main power sits at about 1V. My first thought was that there was some issue with the voltage regulator so I replaced it but that did not resolve the issue (I also tested the voltage regulate I removed off-board and it appeared to function correctly). I also thought the issue might be caused by a bad capacitor so I tried removing most of the bypass capacitors on the board, which had no effect. I checked the datasheet for the MIC5219 and my implementation appears to be correct as far as I can tell. Does anyone have any ideas about what my problem might be or any other tests that I could run to determine what the issue is?

MIC5219 Datasheet: https://cdn-shop.adafruit.com/product-f ... ic5219.pdf

Screenshot of the relevant portion of the Eagle Schematic:
Image

paulvha
Posts: 273
Joined: Sat Nov 11, 2017 2:39 am

Re: Voltage regulator on PCB I designed - not working

Post by paulvha » Thu Dec 28, 2017 6:24 am

I have worked on a board MICS5219 in the past. Nothing wrong that I can see, some thoughts :
I assume you have checked you have +voltage on pin 1 (IN) and pin 3 (enable) is indeed high ?
Did you get the right MICS519 (the MIC5219-3.3BM5 with bypass and NOT the MIC5219BM5 with adj on pin 4 ?)
Is the output 3v3 connected to anything else that might cause a short circuit ? did you measure the resistance ?

Post Reply