PIC18F2455 problem entering debug mode

Find out how to setup your programmer's software and how to solve many common problems.

Moderator: phalanx

Post Reply
coco243
Posts: 2
Joined: Sat Aug 16, 2014 11:00 am

PIC18F2455 problem entering debug mode

Post by coco243 » Mon Sep 08, 2014 11:41 am

Hi,

I have :

- an PIC-ICD2-POCKET programmer/debugger from Olymex
- an PIC-P28-20MHz developing board from olymex too, I will attach it's schematic, you click on it and it will be oppenning.

Image
image upload no registration

- a dsPIC18F2455
- MPLAB IDE v8.87
- MPLAB C18 compliller

When I want to debug it ( Debugger -> Program ) I am not able to enter in debug mode, I recive this error message:
"ICD0083: Debug: Unable to enter debug mode. Please double click this message for more information."

- I have build configuration on debug


I have this code that I want to debug it ( it contains and the configurations bits ):

Code: Select all

#include "p18f2455.h"

#pragma config LVP = OFF
#pragma config WDT = OFF
#pragma config PLLDIV = 1
#pragma config DEBUG = ON
#pragma config PWRT = OFF

int counter;

int main (void)

{

counter=1;
TRISB=0;
while(1)
{ 
PORTB=counter;
counter++;
}

return 0;

}
Can you give me some clues? What should I check? Why should I try?

Thank you.

waltr
Support Volunteer
Posts: 2823
Joined: Tue Sep 08, 2009 12:07 pm
Location: Philadelphia, USA

Re: PIC18F2455 problem entering debug mode

Post by waltr » Tue Sep 09, 2014 7:17 am

Do not set the DEBUG bit in the CONFIG code. Let the MPLAB IDE handle this by setting the "DEBUG" or "RELEASE" selection and then build and load the code.

coco243
Posts: 2
Joined: Sat Aug 16, 2014 11:00 am

Re: PIC18F2455 problem entering debug mode

Post by coco243 » Tue Sep 09, 2014 11:08 am

I did and that too, is not that the problem. Ican't figure what it is.

waltr
Support Volunteer
Posts: 2823
Joined: Tue Sep 08, 2009 12:07 pm
Location: Philadelphia, USA

Re: PIC18F2455 problem entering debug mode

Post by waltr » Wed Sep 10, 2014 7:15 am

Try contacting Olymex to get help with using their stuff.

okayid
Posts: 6
Joined: Mon Sep 15, 2014 2:24 pm

Re: PIC18F2455 problem entering debug mode

Post by okayid » Tue Sep 16, 2014 11:43 am

Is MCLR pin enabled in CONFIG code?
MCLR needed for debug.

Post Reply