SparkFun Forums 

Where electronics enthusiasts find answers.

For the discussion of Arduino related topics.
By henry321yu
Hello guys.
Thank you for taking the time for me.

My board is SparkFun 9DoF Razor IMU M0.
Introduction of the board: ... troduction

I think there's no problem uploading codes via arduino ide through i already did it for few week and offical introduction say so.

There's a problem with my computer while uploading the code to this board.
Port already selected,and still can read the data from the IMU.

The strangest part is my computer still can upload sketches to other board,and other computer still can upload codes to the IMU board...

I don't know where the problem is...
I remember there was a error while i installing new release patch on one of Board manager board,
and it start not uploadable.

So i tried re-install all boards in Board Manager and IDE.
But seems something didn't clean up at IDE.I used cclear after unstall.
I did'nt sure will that do the job,but seems not.Issue still exsist.

And the driver i'm not sure if there has problems.Because it worked at the first day i plugin the IMU board.

The board have no reset button,but it have bootloader mode throgh i still fail.I think there's other way.

I still have subject to do.
I'm counting on you guys :cry: :cry: :cry:
By paulvha
have you selected in preferences "show verbose output during upload". what errror message do you get ?
By henry321yu
hi,the error is changed,it was like this:

Set binary mode
No device found on COM7
Send auto-baud
Set binary mode
An error occurred while uploading the sketch

and now shows:

Set binary mode
No device found on COM7
version()=.32, 90.92, 172.24
Unsupported processor
Send auto-baud
Set binary mode
version()=90.47, 169.84
Unsupported processor
By paulvha
is the device really on com6 (as in the first picture) or com7 (where the IDE is looking)
By henry321yu
YES,it's on com7 because i tried to change the port from device manager,but didn't work out.