[phpBB Debug] PHP Warning: in file /mnt/forum-shared/ext/sitesplat/BBCore/event/listener.php on line 70: in_array() expects parameter 2 to be array, boolean given
Arduino not getting detected - SparkFun Electronics

SparkFun Forums 

Where electronics enthusiasts find answers.

For the discussion of Arduino related topics.
By Bennie4
#201127
Hello all,
I have a pro micro clone (from tenstar robot), and i have some problems, with it (them).
When i received my first clone, i plugged it in, and all the led' s went on, i don't know if this is normal. Windows didn't detect any usb device, so i tried another 10 cables, all didn' t work, and nothing showed up in device manager. So i went to the company where i ordered it, and asked for a new, functional one. Now with the second one i got, i have the exact same problem. Is it just some kind of coincidence that both of them are bricked, is it some problem with my computer, or is it a problem with my windows or linux (I use dual boot in my pc)
btw i already tried installing the ch340 drivers, but because nothing is showing up in device manager, there is nothing to install drivers for.

I' m looking forward to your suggestions :D
By sterretje
#201367
Can't help you, but installing the CH340 drivers will not help. The Pro Micro uses native USB and does not have any additional ICs for communication with the PC.

Maybe you can find some info that can help in 32U4 notes.

[edit]
I've read a couple of times about poor soldering on those clones resulting in no connection between USB port on the board and the micro. If you have a multimeter, you can try to measure.

The USB connector on the board is also a weak point in the design; there have been reports that it easily tears off, even on the original.

I would suggest that you buy at least one original Sparkfun board and test that. You might find that it's not worth the hassle of going through cheap chinese crap.
[/edit]