SparkFun Forums 

Where electronics enthusiasts find answers.

For the discussion of Arduino related topics.
By Nicholas
I am new to Arduino, and I am building an RC plane. I got two new nRF24L01 transceivers from Amazon:

( ... UTF8&psc=1)

but I cannot get them to work. I connected both transceivers to Arduino Unos, with the following connections:

GND to Ground, V+ to 3.3V, CE to Digital 7, CSN to Digital 8, SCK to Digital 13, MOSI to Digital 11, and MISO to Digital 12.

I downloaded the RF24-master library and used the "Getting Started Sketch." I downloaded the code to both Arduinos. In other tutorials, this printed the line "*** PRESS 'T' to begin transmitting to the other node," and then printed lots of information. However, when I ran the program it stopped at the press 'T' command, even though I did press 'T' (am I pressing T wrong?). It was my understanding that even if the transceiver was not functioning properly, it would still print more information. I can't think of anything I did wrong, but like I said I'm new to Arduino, so please don't discount a possible solution if it seems too obvious. I'd appreciate any ideas!
By teprojects1

I have worked on these RF modules NRF24L01 and I must say that I really admire them. Because they are quite easy to use and very cheap. I think you have done everything correctly and I would suggest you to place a capacitor of at least 100 ohm at +3.3V and GND. Your RF Module must be powered up with this 3.3V. I think that will solve your issue. Let me know the results.

By teprojects1
n1ist wrote: Mon Jun 25, 2018 6:10 am
teprojects1 wrote: Mon Jun 25, 2018 1:16 am capacitor of at least 100 ohm at +3.3V and GND.
Make that 100 microfarads...
Hahaha thanks for mentioning and sorry for the mistake ...... yeah its 100 uF capacitor and you should also try 1000 uF capacitor if the first one doesn't work.