Lilypad Simblee error compiling, no such file or directory

For the discussion of Arduino related topics.

Moderator: phalanx

Post Reply
Posts: 5
Joined: Tue Feb 16, 2016 9:56 pm

Lilypad Simblee error compiling, no such file or directory

Post by Clontarf » Thu May 03, 2018 6:01 pm

Upon trying to compile a Blynk file for simblee (Using the Lilypad Simblee BLE) I get the following error:

arm-none-eabi-g++: error: C:\Users\sugar\AppData\Local\Temp\arduino_build_776608/core/syscalls.c.o: No such file or directory

exit status 1
Error compiling for board Simblee.

I have the most recent Simblee board software installed through the arduino board manager. I have followed the Sparkfun simblee tutorial at ... ncepts/all to try to get it to work.

I have found several solutions by google searching the error and none of the solutions worked for me (installing the Arduino SAM boards package was suggested and found to work in several people's situations, but didn't work for me.)

Here's my code, it's just the sample Blynk Simblee code and I have removed my Auth token for privacy:

Code: Select all

  Blynk is a platform with iOS and Android apps to control
  Arduino, Raspberry Pi and the likes over the Internet.
  You can easily build graphic interfaces for all your
  projects by simply dragging and dropping widgets.

    Downloads, docs, tutorials:
    Sketch generator: 
    Blynk community:  
    Social networks:  

  Blynk library is licensed under MIT license
  This example code is in public domain.


  This example shows how to use Simblee BLE
  to connect your project to Blynk.

  NOTE: BLE support is in beta!



#define BLYNK_PRINT Serial

#include <BlynkSimpleSimbleeBLE.h>
#include <SimbleeBLE.h>

char auth[] = "";

void setup()

  SimbleeBLE.deviceName = "Simblee";
  SimbleeBLE.advertisementInterval = MILLISECONDS(300);
  SimbleeBLE.txPowerLevel = -20;  // (-20dbM to +4 dBm)

  // start the BLE stack

  Serial.println("Waiting for connections...");


void loop()

Posts: 3
Joined: Fri Jan 22, 2016 6:38 pm

Re: Lilypad Simblee error compiling, no such file or directory

Post by PAS » Sun Nov 18, 2018 8:32 pm

I had the same problem.
I was using the link from the quick start guide, which is out of date.

For Arduino 1.6.5, use this link:

For Arduino 1.6.7 or later, use the following link: <<<<<This worked for me.

Post Reply