SparkFun Forums 

Where electronics enthusiasts find answers.

For the discussion of Arduino related topics.
By MRbling
#199028
Hi,

I'm currently working on a projekt on which an arduino mini is to receive data from an MaxRS485 module.

The data i'm receiving looks like this:

SN=??072? >?>
SN?000?29 ?<>
?N=0?0729?><?
?N=?007?9 >??
SN?000?29?><>?
SN=?007?9 ><?
SN=00?72? ><?
SN?0007?9 >?>
SN?00?729?><>
S?=0?0729?><>?
S?=0?072? ><??

It's supposed to be:

SN=000729 ><>

What is the typical problem when data gets interfered with like this?

The Arduino Mini and the MAXRS485 has different supply voltages. Could this be the issue?


Thanks
By paulvha
#199035
Even though they are different supply voltages, i assume you have connected the GND/0V otherwise you would not get the data. How much different are the supply voltages ? How have you connected ? Are you using softserial and what speed ? what is the test setup ?
By MRbling
#199042
Yes, softserial. 115200 baud when writing commands to the RS485 device and 9600 Printing it in terminal.
I changed from a arduino mini to an UNO and it looks much better but i still get some interferance from somewhere. I have tried all sorts of signal wires but it dont work.
By paulvha
#199049
Your problem is probably the line speed. If you are lucky softserial works well up to ~57K. (nowhere defined, but had tried it on my UNO). Try reduce the Softserial speed to lower speed ( e.g. 9600) and if that works, try higher speeds.
regards
Paul
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]