SparkFun Forums 

Where electronics enthusiasts find answers.

For the discussion of Arduino related topics.
By Crispy_Cat
#195903
Sorry I know this is going to tick some people off because its probably been asked before. I have a nano, set to nano, ATmega328, /dev/cu.wchusbserial620, ArduinoISP, but the programmer i've tried pretty much all of them. Anyways, i keep getting this error message:Arduino: 1.6.12 (Mac OS X), Board: "Arduino Duemilanove or Diecimila, ATmega168"

Build options changed, rebuilding all
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00

Sketch uses 928 bytes (6%) of program storage space. Maximum is 14,336 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 1,015 bytes for local variables. Maximum is 1,024 bytes.
/Users/svteacher/Library/Arduino15/packages/arduino/tools/avrdude/6.3.0-arduino6/bin/avrdude -C/Users/svteacher/Library/Arduino15/packages/arduino/tools/avrdude/6.3.0-arduino6/etc/avrdude.conf -v -patmega168 -carduino -P/dev/cu.wchusbserial620 -b19200 -D -Uflash:w:/var/folders/_h/cw2_jv2j0kb8m4shtlxb48900000gq/T/arduino_build_603276/Blink.ino.hex:i
Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

avrdude: Version 6.3, compiled on Sep 12 2016 at 17:22:25
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "/Users/svteacher/Library/Arduino15/packages/arduino/tools/avrdude/6.3.0-arduino6/etc/avrdude.conf"
User configuration file is "/Users/svteacher/.avrduderc"
User configuration file does not exist or is not a regular file, skipping

Using Port : /dev/cu.wchusbserial620
Using Programmer : arduino
Overriding Baud Rate : 19200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

avrdude done. Thank you.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

I looked at a few links online and some Arduino pages and articles, but still cant figure it out. I've been at it for two hours, and just want an answer. Thanks you guys!
User avatar
By Ross Robotics
#195920
Google "avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00". It could be a number of things throwing that error.