SparkFun Forums 

Where electronics enthusiasts find answers.

For the discussion of Arduino related topics.
By wangcheung
#189568
I have been using the Arduino IDE ver 1.67 to develop a demo using the qduino mini. I didn't change or update anything but suddenly I can no longer compile a previously working project with the following error:

"Arduino: 1.6.7 (Windows 7), Board: "Qduino Mini"

Board qduinomini (platform avr, package SparkFun) is unknown

Error compiling."

I selected Tools and the Board and found that none of the sparkfun boards were listed anymore. I launched the Boards Manager and scrolled to the Sparkfun AVR boards and saw that I could select Install, so I did. The sparkfun boards were not listed in the boards list so I selected the Qduino Mini again but I still can't compile even though the manager shows Sparkfun AVR Boards by Sparkfun Electronics version 1.1.4 INSTALLED is listed.

I can load an example sketch for the Qduino but it displays the same error message posted above.

Any help would be appreciated. Also, what can change in the IDE without my intervention???

I did make one, change. I connected a second qduino mini since the first was working well. Are there different versions of the preloaded firmware available, and can that affect the IDE???

update --- I found that I can't select ANY sparkfun arduino boards. They all fail compile with the same error. Apparently the sparkfun driver has failed somehow even though the board manager states it's installed.

Thanks,

Dan
By wangcheung
#189597
I finally found the issue. I navigated to the folder where the arduino boards are stored in windows and found that an older version of the sparkfun drivers was present after removing the drivers using the board manager. Users>AppData>>Local>>Arduino15>>packages>>Sparkfun>>hardware>>avr>> and I found a folder 1.1.3 even thought the board manager was installing and removing 1.1.4 when I would add or remove the sparkfun arduino boards. After manually deleting the 1.1.3 folder and then using board manager to install the Sparkfun Arduino boards everything worked perfectly. The IDE was leaving behind an older version of the boards for some reason. Anyhow, worked for me.

Thanks for your response darrellg