SparkFun Forums 

Where electronics enthusiasts find answers.

For the discussion of Arduino related topics.
By ddesson
#138294
cbernett wrote:hello!

i've gotten the WIFLY up and running at home with my airport express (WPA2), but am needing to transfer my whole setup to work, where I also have a secure WPA/WPA2 network, but am having trouble connecting to it. I'm using the library designed for it and it just hangs. so i thought i'd try your troubleshooting sketch, but am not able to get into command mode at all. in fact, following is what i see, with no response from the IDE when i enter $$$:

--------------------------------------

This is a tool to help you troubleshoot problems with the WiFly shield.
For consistent results unplug & replug power to your Arduino and WiFly shield.
(Ensure the serial monitor is not open when you remove power.)

Attempting to connect to SPI UART...
Connected to SPI UART.

* Use $$$ (with no line ending) to enter WiFly command mode. ("CMD")
* Then send each command followed by a carriage return.

Waiting for input.

WG÷·—77÷·Ø@'÷7o¶Þw·˜@774Á緟`±·ßG·±yç¶6¶¡@g¶ ‘Ƕ¡ˆ×0ÁWG÷·—77÷·Ø@'÷7o¶Þw·˜@774Á緟`±·ßG·±yç¶6¶¡@g¶ ‘Ƕ¡ˆ×0ÁWG÷·—77÷·Ø@'÷7o¶Þw·˜@77¶Á緟`±·ßG·±yç¶6¶¡@g¶ ‘Ƕ¡ˆ×0ÁWG÷·—77÷·Ø@'÷7o¶Þw·˜@774Á緟`±·ßG·±yç¶6¶¡@g¶ ‘Ƕ¡ˆ×0ÁWG÷·—77÷·Ø@'÷7o¶Þw·˜@774Á緟`±·ßG·±yç¶6¶¡@g¶ ‘Ƕ¡ˆ×0ÁWG÷·—77÷·Ø@'÷7o¶Þw·˜@77¶Á緟`±·ßG·±yç¶6¶¡@g¶ ‘Ƕ¡ˆ×0ÁWG÷·—77÷·Ø@'÷7o¶Þw·˜@77¶Á緟`±·ßG·±yç¶6¶¡@g¶ ‘Ƕ¡ˆ×0ÁWG÷·—77÷·Ø@'÷7o¶Þw·˜@774Á緟`

This goes on for as long as I let it run. Any ideas?

Thank you so much!
c
I have the same problem. Were you able to find a solution?
Thank you
By qoda
#139322
I’ve been battling the entire weekend with the WiFly shield (Connected to a Arduino UNO). I know think I’ve exhausted all possible steps in debugging this issue. I have also tried this with all versions and some forks of the code and version 0022 and version 1.0 of the IDE.

After uploading and running SpiUartTerminal.pde or the HardwareFactoryReset.pde, the serial monitor just hangs after outputting “Waiting for input:” and doesn’t allow me to enter the command line application ($$$). I’ve tried unix screen, coolterm and the standard IDE serial monitor. I’ve also tested the pins to ensure everything is connected correctly (I finally soldered them to the header pins) and I’m sure it is.

I would really appreciate some help if possible. I’m now suspecting that it is in fact a hardware issue.
By lfwo63
#140102
Heey guys....

I had no trouble using the wifly shield until it started behaving weirdly (thats what i thought).It will go on for a while then off completely. I have done hardware reset through uploading the hardwareReset.pde or by sending factory reset command through serial monitor/tera term. It was fully functional before as I was able to associate to any network then two days ago this happened. Does this mean the device is defective and I have to get a new one or its some modification somewhere that is needed...I havent soldered anything on the prototyping area...please help!!!!......
By lfwo63
#140121
When it is on i get this message

WiFly Shield Terminal Routine
Bridge initialized successfully!
CMD
Auto-Assoc roving1 chan=1 mode=NONE FAILED

Then i can continue passing the commands to join the preferred network. But when it goes off it doesnt accept and respond to any command. The terminal doesn't show the commands that am sending..it is like being switched on and off by the arduino in random cycles (since i couldnt determine the pattern of it going on and off).
By strykeroz
#140136
Hi

While it's not clear to me from that text what is going wrong, since it's trying to join the WLAN at Roving Networks the settings do appear to be back to factory as you'd suggested. I'd recommend using the terminal to do a get everything to see what all the settings are. There's bound to be something in there that's incompatible with your local setup. For example the security is likely not going to be right. It would be worth in my view updating the settings to reflect your network SSID, passphrase, security etc to see if it will join automatically.

Good luck !
By lfwo63
#140138
There is no problem in joining networks but the issue is that after a while the device just goes off (no LED blinking) then it cannot be pinged or TCP connection cannot be established with it from a PC. Here is 'get everything" command response.

<2.23> get everything
WiFly Ver 2.23, 04-26-2011 on 131C11
Beacon=100
Probe=5
OPEN=*OPEN*
CLOSE=*CLOS*
REMOTE=*HELLO*
FlushSize=64
MatchChar=0
FlushTimer=10
IdleTimer=0
CmdChar=$
IF=UP
DHCP=ON
IP=192.168.1.9:2000
NM=255.255.255.0
GW=192.168.1.1
HOST=192.168.1.2:19999
PROTO=TCP,
MTU=1524
FLAGS=0x7
BACKUP=0.0.0.0
DNS=192.168.1.1
Name=server1
Backup=backup2
FTP=208.109.78.34:21
File=wifly-GSX.img
User=roving
Pass=Pass123
Dir=public
Timeout=40
FTP_mode=0x0
SSID=Alhabsy
Chan=0
ExtAnt=0
Join=1
Auth=WEP
Mask=0x1fff
Rate=12, 24 Mb
Linkmon=0
Keynum=1
Key=.......................................
SleepTmr=0
WakeTmr=0
Trigger=0x1
Autoconn=0
IoFunc=0x0
IoMask=0x20f0
IoValu=0x0
PrintLvl=0x1
TimeEna=0
TIMEADR=129.6.15.28:123
Zone=7
Baudrate=9600
Flow=0x0
Mode=0x0
JoinTmr=1000
Replace=0x24
DeviceId=WiFly-GSX
Password=
Format=0x0
Signal=0
Average=5
BCAST=255.255.255.255:55555
Interval=0x7
Sensor=0x0
SensePwr=0x0
<2.23> show net
SSid=Alhabsy
Chan=1
Assoc=OK
Rate=12, 24Mb
Auth=OK
Mode=WEP
DHCP=OK,renew=64694
Boot=667
Time=FAIL
Links=1
<2.23> show connection
8130

Then it goes on again for a while then off. I thought maybe sys parameters such as sleep are activated but i disabled them (setting to 0) but still same result.
By Leeu
#140176
Hi,

I have followed this post and I can only get as far as attempting to connect. Your post then says if you cannot connect then this tool will not be able to help. I have looked everywhere and I cannot find how I can get any further. Everything seems to flash as it should when connected.

Please could somebody help. I have read the user manual and command reference guide but that is geared towards windows users, which wouldn't be so bad if I could get to the connected to SPI UART stage.

I'm using Mac OSX 10.7.3 an Arduino Uno and the WiFly shield.

SPI SPI UART on WiFly Shield terminal tool
--------------------------------------

This is a tool to help you troubleshoot problems with the WiFly shield.
For consistent results unplug & replug power to your Arduino and WiFly shield.
(Ensure the serial monitor is not open when you remove power.)

Attempting to connect to SPI UART...
By VirtualEnder
#141611
I have an odd problem, I am able to successfully connect to my WiFly and issue commands, get results, etc. But when I do a scan it returns 0 results even though I know I have multiple networks available (I'm on one right now). I even tried lowering the connection speed and moving closer to the AP but no luck. Am I looking at a bad module or am I missing something? I bought it a while ago and am just now getting around to testing it, so I hope I can get a return from sparkfun if it is a bad board.
By zjacobso
#142641
Hey gang. I'm with Leeu on this. I have looked at everything Sparkfun offers for support and can't get past go on Mac. Maybe I'm a noob. But wasn't everyone?

I could use a coherent step-by-step on configuration. I'm using WiFly 2.21 RN-131C. I need to know:via what application , how do I get into CMD mode with my WiFly Shield (for Arduino)?

The only library example code that will compile is WiFly_Serial > WiFly_Test. All other example code and tutorials have multiple errors, mostly pertaining to Arduino v.1 IDE.

Help me Obi-Wan Kenobi, you're my only hope. Thanks in advance for any help.
By knitsu
#145467
Certain WiFly libraries, you have to use Arduino V. 0023

I notice the typical one from Arduino's website does not work well with 1.0.1, and found a post saying try ver 0023 (forget where the link is, found it thanks google! http://arduino.cc/hu/Main/Software Scroll down and search for 0023 under previous versions)

This should do the trick, and always be sure to #include WiFly.h if your using WiFly.

I am just getting into the whole Arduino scene the past two weeks, and am building some prime tutorials/youtube, as I want to show people and encourage people to learn and get this stuff working properly, even though I agree with some of the advanced people in this forum, giving and writing all your source code, takes out all the fun

:-) cheers
By knitsu
#145545
Gary_BSEE, your code was amazing....


(side note)No Relevance to this post except the fact that I am also Troubleshooting the WiFly shield.....

....it helped me understand how to send signals to my WiFly, such as Auth levels, I managed to rip through the code, cut out all the stuff I don't need, and got it working, however left with one other issue, the main place I work, they have an SSID of "Name Here" yep with a space!!!! I know the book says to replace $ for the space, however it does not work, however when I am at home on my personal network, setup exactly the same as my work network, except without the space, it connects and works fine, any idea idea??
By asfarley
#155700
I'm having the same problem as above. SpiUartTerminal fails at "Attempting to connect to SPI Uart..."

The WebClient example hangs at WiFly.begin(); also.

I'm using an Uno R3. I've tried with Arduino 1.00, 1.003 and 0023 and the same thing always happens. This is using the most recent version of the code pulled from Github.

Can someone point to a recently tested good configuration?
By allanba
#157751
Hello,

I've had this shield for about five months now, I programmed the arduino to log information to a home web server every 10 minutes and it ran with no problems for three of those five months. I however changed the ratio at which the arduino logs information from as said 10 minutes to 1 second after that I can't seem to get a stable link longer than 20 hours. Whenever the shield hangs only the green and yellow leds blink, the green one a bit faster than the yellow. It seems to be some sort of problem with the library, that also does always return true to a connection,whether there is a connection or not to any host.
Is there a way that I can increase the reliability of the library?


Cheers.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]