SparkFun Forums 

Where electronics enthusiasts find answers.

For the discussion of Arduino related topics.
By Toddah
I am trying to control some servos (futaba3004) using my Arduino 2650. I can plug a single servo into the Arduino power and ground circuts and using an example sweep program I get everythng to work as it should. However when I switch the servo power over to a wall wart power supply and I run my arduino sketch the servo goes to one extreme of travel motion and stalls there.
I have tried different power supplies (2)
Tested output voltage on both supplies and they are within the expected range. (1) 5.18Vdc (2) 6.181Vdc
Tried 4 different servos
I have tied the Servo ground the Adrino ground and the power supply ground together on my breadboard but alas same problem.

Is there an issue using a wall wart to power the servos like ripple or noise?

I am stumpped here, can anyone lend some light?

By esklar81

If you provide a wiring diagram, there's a better chance someone will be able to help you.

Also, try powering the servo from a suitable battery, rather than a wall wart. If that works, then the wall wart's worth investigating. If using an external battery gets you the same behavior, I'd look at the wiring, not the power supply.

Lastly, how are you powering the Arduino?

Good Luck,
I have my Arduino powered by my USB port on my Sony laptop.
Tonight I will try powering the Arduino from the 5V power Supply and see it if resolves the issue.
I will also try a dry cell on the Servo power.
You do not have the required permissions to view the files attached to this post.
Solved my own problem. Stupid wiring tricks.
I found when I was hooking the gnd to the Arduino from the servos and the external PS I was hooking it in the Gnd on the power header not the signal header :oops:
As soon as I moved the wire it took of and has been working fine :)
Thanks for the help!!