SparkFun Forums 

Where electronics enthusiasts find answers.

Questions relating to designing PCBs
By elabudde
#50143
Hi all. I am not an Eagle power user, and I have learned a lot here. I am having a problem with the operation of Eagle on a new computer with Windows XP. I installed 4.16r2 on my new computer. At first everything was fine. When I clicked on “add” the entire list of libraries appeared. This is the same way it had worked on my old computer. Today, I opened it up and clicked on “add” and there were no libraries showing! I had to click on “libraries use” to get some installed. After I install them and exit, I have to go through the same process each time I power up.

Here are the questions: 1) why did the operation change? 2) What is the normal way Eagle is supposed to operate? 3) Is there a way to save the installed libraries so I don’t have to do it every time?

Thanks for the help, Ed.
By Philba
#50176
Is it possible you put a search term in the lower left search box? put gibberish in and you will get no matches. It's easy enough to do.
User avatar
By bigglez
#50181
Greetings Ed,
elabudde wrote:I am having a problem with the operation of Eagle on a new computer with Windows XP. I installed 4.16r2 on my new computer.
I just upgraded to 5.0 from 4.16R2, so from memory...
elabudde wrote:1) why did the operation change?
The new installation does not have your old config file(s)
elabudde wrote:2) What is the normal way Eagle is supposed to operate?
Anyway you wish (within their narrow range of options) - once you
have a comfortable setting you should make it the defaut.
elabudde wrote:3) Is there a way to save the installed libraries so I don’t have to do it every time?
Sure, first read this section of the Cadsoft EAGLE FAQ,
check to see if your old config files (noted in the
FAQ) are still on the old machine and copy them
across (or hack the new defaults found in the new
installation on the new machine).

Make back up copies first.

Comments Welcome!
By Lucien
#50233
Is it something to do with whether or not a project is "open" and libraries are in "use" from the control panel? I've found that I can open a project (and not simply open the files in the project) and pick which libraries are used, and Eagle wll remember that for that specific project. Or in other words, which librarires are available in the editors can be configured on a per-project basis.
By elabudde
#50322
Thank you all for the posts. It got me thinking about what happened. As best I recall, some time after I installed Eagle, I looked at the Project examples. Eagle got it into its head that it would make that the default directory on power up. I was unable to teach it other wise. As Lucien pointed out there are no libraries selected for this project, hence my having to add them for use.

I was able to convince Eagle to stop doing this by deleting the project folder. Then like magic it started working like it used to with all the libraries showing on power up.

In the process I made a new library folder and copied the ones I use most into it. Then linked it in on the directory path. Now I am a happy camper.

Thanks again, Ed.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]