SparkFun Forums 

Where electronics enthusiasts find answers.

User avatar
By mkjones
I've got a Redboard Nano, and I've soldered in the 2x5 pin header ( I have a j-Link BASE Compact (, and the 20-pin to 10-pin adapter ( I've installed the j-Link software from Segger, and Mbed Studio sees it (on the Manage Custom Targets dialog)

But I can't figure out what to select for "Deploy and debug target". It just says "None (use mass storage copy for deploy), which of course is not an option for the Nano. I *thought* the j-Link pod would allow me to download code to the nano, and also to debug it. What boat am I missing?

TIA for any help,

User avatar
By rpiloverbd
Since j-link is for programming and Debugging ARM boards, it should be able to do so with ARtemis Redboard Nano too. That means the problem is not in compatibility, but somewhere else. Let's wait for team sparkfun to answer.
User avatar
By mkjones
I'm really stuck here, so if anybody has any suggestions, I would welcome them.

I was able to download code using the Segger JFlash Lite program (and using the .hex file generated by Mbed Studio). So I know the JTAG connector is soldered in properly, and that I've connected the j-Link to it successfully.

But I cannot get anything to work from withing Mbed Studio. It *sees* the j-Link, and I have to manually tell it to use the SFE_ARTEMIS_NANO target. The only "Deploy and debug target" in the list which look promising is the "cortex_m (Native)" entry. I tried it, but no dice:

When I build the project, I get these two errors right off the bat:

Configuration error: Bootloader not supported on this target. ROM start not found in targets.json.
Configuration error: Bootloader not supported on this target. RAM start not found in targets.json.

If I try Debug after the build completes, it complains about not being able to connect the the gdb server. If I just click the Run button, it starts a background task "Erasing...", which never completes (and does not seem to be doing anything to the Nano; the program on it is still happily running).

So, any suggestions for how to move forward are greatly appreciated.


User avatar
By Airheadbit
Artemis ATP fail same way. First the install from both Sparkfun and Element 14 show they have a Jlink attached yet it was my understanding I could program using the USB C connector. Second was Mbed ignoring the jlink, not able to find the board, after a few hours of screwing around I found a post here about 'search for SFE' and it gave me a pick list with the ATP board. I compiled (why every library known on earth?) the blinky, same errors you got, I think it was looking for a drive to use. 3 years ago I got tired of Mbed constantly changing the API forcing countless hours of rewrite, I left.
I too tried the Jlink lite BUT what is the MCU we use, there was two with 1MB of flash so I had a 50/50 shot, guess not, it failed to write the bin file.

At any rate I get to wait on another Artemis ATP, when mine arrived today it had been shipped in an envelope, not a padded envelope or a thick paper padded envelope just a sheer plastic envelope and the device was not wrapped in bubble pack or anything for that matter. The sockets were smashed flat, whey were surface mount female .1" headers, they are pancakes now.

I'll go look at the SDK forum and see if I dare try that.
Best of luck to ya.
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum