SparkFun Forums 

Where electronics enthusiasts find answers.

#224898
I am unfortunately dealing with Arduino Portenta and the Artemis issues at the same time. One needs a very specific version of Arduino and now I am running into issues with the Artemis setup.

I have tried Windows 10 with Arduino Pro, Windows 10 Arduino 2.0, Arduino 1.8

I have also tried Linux with Arduino 1.8, same error message

Upload error: Error: 2 UNKNOWN: cannot get programmer tool: undefined 'upload.tool' property
#225658
That likely means the board definition ('boards.txt') file is missing some needed parameters - perhaps instead of jumping around between several IDEs, try Arduino's cloud version for free https://www.arduino.cc/en/IoT/HomePage and see if that yields different results? (It's what they recommend for the Portenta)

Hope this helps!
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]