SparkFun Forums 

Where electronics enthusiasts find answers.

User avatar
By gDFfRc7VvzfYydHP
#221472
Hi,

I am on Linux (Ubuntu 20.04).

I followed the instructions available here: https://learn.sparkfun.com/tutorials/ar ... s-beta/all

- I installed the latest mbed-studio version (v 1.3.1), including the udev rules setup

- I cloned the sparkfun mbed repo, checked it out in the right version, and use it within mbed-studio

I am then able to compile the blink example for the Artemis DK, but for some reason the "connect to a platform" button is greyed out, and I cannot find the board in the Target section (see screenshot).

- Any idea why this happens / how to fix?

- Can this be due to DAP versions? https://armmbed.github.io/DAPLink/

- I think the board is well recognized by the computer (just FYI, dmesg output):

```
[ 4745.664488] usb 1-1: new full-speed USB device number 12 using xhci_hcd
[ 4745.814585] usb 1-1: New USB device found, idVendor=1a86, idProduct=7523, bcdDevice= 2.64
[ 4745.814592] usb 1-1: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[ 4745.814596] usb 1-1: Product: USB Serial
[ 4745.816998] ch341 1-1:1.0: ch341-uart converter detected
[ 4745.818249] usb 1-1: ch341-uart converter now attached to ttyUSB0
```
User avatar
By gDFfRc7VvzfYydHP
#221473
Screenshot: as you see, was able to build, but cannot upload.
You do not have the required permissions to view the files attached to this post.
User avatar
By Karrde
#222623
I have the same issue:
  • Artemis Nano
  • Windows 10
  • Mbed Studio 1.3.1
  • mbed tools.png
You do not have the required permissions to view the files attached to this post.
User avatar
By Karrde
#222628
When I begin compiling with an SFE_ARTEMIS target, I get the following lines:

Configuration error: Bootloader not supported on this target. ROM start not found in targets.json.
Configuration error: Bootloader not supported on this target. RAM start not found in targets.json.
User avatar
By gDFfRc7VvzfYydHP
#222638
Small side note: I was looking into MBedStudio a few weeks ago as I could not get the "Arduino MbeOS Sparkfun core" to work. But it has got much better recently, so now the code there:

https://github.com/sparkfun/Arduino_Apollo3

Together possibly with the Platformio core here:

https://github.com/nigelb/platform-apol ... ee/Core_V2

Start to be a quite nice environment :) (though there are still a few things to iron out).
User avatar
By Destinee2
#226351
Karrde wrote: Sat Jan 23, 2021 10:28 pm I have the same issue:
  • Artemis Nano
  • Windows 10
  • Mbed Studio 1.3.1
  • mbed tools.png
Did you have a fix on this issue? Facing same issue but no response from anyone and couldnt find this topic troubleshooting in google.
User avatar
By sparkfun@cbauer.net
#227109
I'm having the same issue with Mbed Studio 1.4.1/ Did anyone ever find a solution to this?
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]