SparkFun Forums 

Where electronics enthusiasts find answers.

Discussions about processor boards have here!
User avatar
By zrpurser
This is my first experience with Sparkfun products so it's possible I'm doing something wrong, but I am trying to connect the RedBoard to my laptop via USB and it is simply not working. The board is receiving power but no connection is visible on the USB. I have tried two different RedBoards, three different USB cables, and two different Windows 10 laptops using two different USB tree viewer programs. Regardless of what I do the boards will not show up as a USB connection. The ON LED remains solid green, the 13 LED flashes blue, and the TX LED flickers green briefly before the 13 LED flashes. This behavior is consistent on both boards. I have tried powering them via USB and also using a 9v battery and it doesn't make any difference. Please advise.
User avatar
By zrpurser
YellowDog wrote: Thu Nov 02, 2023 6:58 pm Ate you sure your usb cables are data cables? Some only provide power for charging.
That was my first suspicion but I'm sure the second two USB cables I tried are data cables. I'll see if I can find some other device to connect using mini-B to validate the cables are good.
User avatar
By YellowDog
If it's not the cable, it's going to be a bad FTDI/CH340.
Sparkfun is pretty good at helping you out when these things happen.

Happy (future) hacking!
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum