SparkFun Forums 

Where electronics enthusiasts find answers.

Discussions about processor boards have here!
User avatar
By toneware
#224681
I have an ESP-32 module in a Weather Carrier board. So far, I have not been able to run even the simplest example sketch. After figuring out that I have to hold the boot button to connect (and asking myself why this is even a thing and why is it not mentioned anywhere in the setup page), I am now stuck on the "Leaving... Hard Resetting Via RTS Pin" rabbit hole.

I followed the directions and am still unable to run a sketch on my device. I've uploaded screenshots of the IDE Board settings as well as the output of the upload process.

I have successfully used MCU boards to send data via MQTT over Wifi, so I'm pretty confident that my toolset is working.

Please advise.
You do not have the required permissions to view the files attached to this post.
By sterretje
#224703
That seems to be normal for ESP 'stuff'. Just getting started with Wemos )ESP8266) and have observed the same. Board with uploaded code however does what it's supposed to do.
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]