SparkFun Forums 

Where electronics enthusiasts find answers.

Discussions about processor boards have here!
User avatar
By Czar1249
#249824
Hi there,

I've got four RedBoard QWIICs that I'm using with the SGP40 and BME280 QWIIC breakouts. Three of them work fine via USB 2.0 on my Ubuntu Server 22.04 system. The fourth, however, simply does not cooperate.

When I plug it into the Ubuntu computer's USB 2.0 port, I get 1 TX blink, 1 less-bright RX blink immediately after, and then 2 Pin 13 LED blinks immediately after that. I have triple-checked and it is definitely blinking 13 TWICE and not three times. It will SOMETIMES start to connect if I hold the Reset button on the board until I see the RX LED blink and then immediately let go (the timing seems to be important). Sometimes, even on Windows 10, the Reset button trick doesn't even work (like I said, the timing seems to be important). The BEST I have gotten from this sensor is the following (output from
Code: Select all
'sudo dmesg | tail --lines=20'
):
Code: Select all
[867216.918592] usb 1-12.4.1: new full-speed USB device number 70 using xhci_hcd
I have already manually installed CH340 drivers as per the forum post recommended in the Linux section of the How To Install CH340 Drivers instruction page. All three other boards do not display this behavior, although they are not perfectly identical (one of them has a differently-colored Pin 13 LED, blue instead of green).

Before today, this was the DMESG response (same command as above):
Code: Select all
[ 4098.578930] usb 3-1.1.1: new full-speed USB device number 13 using xhci_hcd
[ 4108.334715] usb 3-1.1.1: Device not responding to setup address.
[ 4118.170924] usb 3-1.1.1: Device not responding to setup address.
[ 4118.378527] usb 3-1.1.1: device not accepting address 13, error -71
I was able to connect to, reprogram, and read the Serial Monitor messages from this board on Win10 in the Arduino IDE. Please help! :cry:
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum