JTAG on Broadcom SoC in Router

Open source ARM Debugger

Moderator: phalanx

JTAG on Broadcom SoC in Router

Postby eastwind » Sun Jul 02, 2017 2:55 pm

Hi,

Just wondering if anyone has experienced something similar - I have a router and I'm trying to JTAG it. This one runs a BCM63138 SoC which has some dual core Cortex A9 ARM CPU and a nice 20pin ARM JTAG header on the board.

I've soldered on some wires and double and triple checked they are correct, and then I've hooked it up to OpenOCD running on a RPI. Strangely, OpenOCD finds nothing on the chain (0x0 response) when only TDO, TDI, TCK and TMS are connected. However, as as soon as I connect TRST (t-reset), it finds the following on the chain:

Code: Select all
Info : BCM2835 GPIO JTAG/SWD bitbang driver
Info : JTAG only mode enabled (specify swclk and swdio gpio to add SWD mode)
Info : clock speed 10 kHz
Info : TAP derp1.dap does not have IDCODE
Info : TAP derp2.dap does not have IDCODE
Info : TAP auto0.tap does not have IDCODE
Info : TAP auto1.tap does not have IDCODE
Info : JTAG tap: auto2.tap tap/device found: 0x800030fb (mfg: 0x07d (Media Vision), part: 0x0003, ver: 0x8)
Info : JTAG tap: auto3.tap tap/device found: 0xf7b3a1ff (mfg: 0x0ff (<invalid>), part: 0x7b3a, ver: 0xf)
Error: derp1.dap: IR capture error; saw 0x0f not 0x01
Warn : Bypassing JTAG setup events due to errors
Error: Invalid ACK (0) in DAP response
Error: Debug regions are unpowered, an unexpected reset might have happened
Error: JTAG-DP STICKY ERROR
Error: Invalid ACK (0) in DAP response
Error: Debug regions are unpowered, an unexpected reset might have happened
Error: JTAG-DP STICKY ERROR
Error: Invalid ACK (0) in DAP response
Error: Debug regions are unpowered, an unexpected reset might have happened
Error: JTAG-DP STICKY ERROR
Error: Invalid ACK (0) in DAP response


However, this is strange because it does not actually issue a Reset yet, so it shouldn't be doing any pull-up of TRST - making it odd that this is required to find the chain (unless I've misunderstood when it issues a pull-up on TRST).

Anyone have any similar experiences/suggestions?

Could JTAG be somehow software disabled on the main CPU? Is it normal/an error to discover cpus without any IDCODE or invalid ones as above?
eastwind
 
Posts: 1
Joined: Sun Jul 02, 2017 2:52 pm


Return to OpenOCD

Who is online

Users browsing this forum: No registered users and 1 guest