iMote2 reset using OpenOCD

Open source ARM Debugger

Moderator: phalanx

Post Reply
ponny213
Posts: 1
Joined: Tue Dec 16, 2014 9:59 am

iMote2 reset using OpenOCD

Post by ponny213 » Tue Dec 16, 2014 10:56 am

Hello

I am trying to install Linux on iMote2. I am using a olimex-arm-usb-tiny-h interface with openocd in Ubuntu.
I can login to telnet in openocd now. But when I am trying to reset halt in my iMote2. I got errors:

Code: Select all

ponny213@yang-Ubuntu:~$ sudo telnet 127.0.0.1 4444
[sudo] password for ponny213: 
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.
Open On-Chip Debugger
> reset halt
JTAG tap: imote2.cpu tap/device found: 0x79265013 (mfg: 0x009, part: 0x9265, ver: 0x7)
Bad value '00' captured during DR or IR scan:
 check_value: 0x02
 check_mask: 0x07
JTAG error while writing DCSR
Bad value '00' captured during DR or IR scan:
 check_value: 0x02
 check_mask: 0x07
JTAG error while writing DCSR
Bad value '00' captured during DR or IR scan:
 check_value: 0x02
 check_mask: 0x07
JTAG error while writing DCSR
Bad value '00' captured during DR or IR scan:
 check_value: 0x02
 check_mask: 0x07
JTAG error while writing DCSR
Bad value '00' captured during DR or IR scan:
 check_value: 0x02
 check_mask: 0x06
JTAG error while reading TX
error while polling TX register, reset CPU
target state: halted
target halted in ARM state due to undefined, current mode: User
cpsr: 0x00000000 pc: 0x00000000
MMU: disabled, D-Cache: disabled, I-Cache: disabled
Here is my openocd configuration:

Code: Select all

root@yang-Ubuntu:~/openocd# sudo openocd -f interface/olimex-arm-usb-tiny-h.cfg -f board/crossbow_tech_imote2.cfg
Open On-Chip Debugger 0.7.0-rc2 (2014-12-16-12:36)
Licensed under GNU GPL v2
For bug reports, read
	http://openocd.sourceforge.net/doc/doxygen/bugs.html
Info : only one transport option; autoselect 'jtag'
adapter speed: 6000 kHz
adapter_nsrst_delay: 260
jtag_ntrst_delay: 250
Info : imote2.cpu: hardware has 2 breakpoints and 2 watchpoints
adapter_nsrst_delay: 800
trst_and_srst separate srst_gates_jtag trst_push_pull srst_open_drain connect_deassert_srst
Info : max TCK change to: 30000 kHz
Info : clock speed 6000 kHz
Info : JTAG tap: imote2.cpu tap/device found: 0x79265013 (mfg: 0x009, part: 0x9265, ver: 0x7)
Info : accepting 'telnet' connection from 4444
Any suggentions why this happened and how to solve this?

Thanks!

Yang

Post Reply