SparkFun Forums 

Where electronics enthusiasts find answers.

Open source ARM Debugger
By allanw
I'm using Ubuntu 10.04 and I can't get /proc/bus/usb to mount: mount: unknown filesystem type 'usbfs'

Do I need to just compile a custom kernel? I've tried symlinking /dev/bus/usb to it but there is no /proc/bus/usb/devices file.

I'm trying to get my Olimex ARM USB Tiny to communicate with the STR711 dev board.
By drwho9437
The ARM-USB-TINY should not need anything custom to work at all (FTDI driver is in the kernel if you build openOCD you will have to include FTDI library support), I used it with the openOCD 0.3.1 binary that was in the Ubuntu 10.04 package sources...

I haven't tried it since moving to 0.5.something dev because it works better with Luminary devices.

You have a different board but I found this:

a reasonable guide when getting started. Most of the steps will be the same.
By allanw
This is all I get in dmesg when I plug the Olimex JTAG Tiny in:

[75137.032791] usb 8-1: new full speed USB device using uhci_hcd and address 2

But lsusb says: Bus 008 Device 003: ID 15ba:0004 Olimex Ltd. OpenOCD JTAG TINY

On the site you said, his dmesg had messages like "usb 3-1: Detected FT2232C". So does that mean my kernel is missing the FT2232 driver?
By allanw
Ahah. Doing: "modprobe ftdi_sio" didn't do the trick. I had to do:

modprobe ftdi_sio vendor=0x15ba product=0x0004

Pretty obscure and annoying to have to figure out. Now I got ttyUSB0 and ttyUSB1 to show up. But OpenOCD still didn't work with this interface file which came by default (with modifications for the desc and pid):
interface ft2232
ft2232_device_desc "Olimex Ltd. OpenOCD JTAG TINY"
ft2232_layout olimex-jtag
ft2232_vid_pid 0x15ba 0x004
Searching around, I used Balloonboard's interface file which finally worked. All it had was an extra:
if { [info exists FT2232_SERIAL] } {
ft2232_serial $FT2232_SERIAL
Hopefully this can benefit someone else.