SparkFun Forums 

Where electronics enthusiasts find answers.

Hardware or product specific questions are best asked here.
User avatar
By prittenhouse
#228615
Hi,

I'm just getting started with my new Artemis Dev kit https://www.sparkfun.com/products/16828

I am trying to install the Windows 7 port driver as described on this page: https://learn.sparkfun.com/tutorials/ge ... e-overview which led me to these instructions: https://os.mbed.com/docs/mbed-os/v6.14/ ... river.html

According to those instructions the device should mount as an Mbed drive when plugged into the USB port but I always get "Unknown device". This prevents the driver installer from recognizing the attached device so it fails. Based on the system info (see attached) it looks like the USB negotiation is failing (IDs are zero)

I tried a different Windows 7 PC and got the same results. I thought it might be the device or the cable but I was able to borrow a Win 10 laptop and it worked fine there.

Is Windows 7 supported? Has anyone got this working on Win 7?

I am running Windows 7 Home Premium SP1 on 64-bit Intel i3

Thanks!
You do not have the required permissions to view the files attached to this post.
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]