SparkFun Forums 

Where electronics enthusiasts find answers.

Hardware or product specific questions are best asked here.
#219542
Dear Sparkfun,

Recently got a Sparkfun DEV-16832
And a Sparkfun GPS-15712
These are connected via a 50mm Qwiic cable. Both boards have red LED illuminated, the GPS board has flashing Blue LED illuminated.

The Firmware on DEV-16832 is set to OpenLog_Artemis-V10-v16.bin

A USB-C cable connects to the Sparkfun DEV-16832 board using a Hyperterminal set at 115kbaud, pressing the reset button the unit reports following details at boot,

D init failed (second attempt). Is card present? Formatted?
Config file read failed: SD offline
Artemis OpenLog v1.6
ICM-20948 failed to init.
SD card offline
Datalogging offline
Serial logging offline
IMU offline
Identifying Qwiic Devices...
Autodetect complete
Device config file read failed: SD offline
GPS-ublox online at address 0x42

It can see the attached GPS board, and GPS co-ordinates are streaming and displayed at 100Hz rate but doesn’t seem to recognize the onboard IMU and temperature sensors and at boot it reports its IMU chip ICM-20948 is offline.

From the main menu option 3 shows the IMU logging and all IMU sensors are enabled but can’t see any IMU data in data stream viewing on Hyper terminal.

Grateful if you can advise how to enable the IMU logging on this device, thank you.

Regards,
Nick :)
#219545
Hi Nick,
The IMU is fully tested during production, so it is unlikely to be a hardware fault.
If you have one available, could you please insert a micro-SD card (formatted with FAT32) and see if that makes a difference?
(Your issue might be due to the boot process being slightly quicker without the SD card present.)
Many thanks,
Paul
#219548
Thanks just tried with FAT 32 16GB SD card, but still have unresponsive IMU. Am powered via the connecting USB -C cable to a PC. Will try connecting a 1 A/hr lithium battery to the board see if it needs a bit more current to get going else I don't know what to try except order some replacement boards from your UK distributor Mouser Electronics.
#219549
Hi Nick,
Could you please try one more test?
Please use menu 1 to change the "Log rate in seconds between readings" to 5.
The OLA will log once every 5 seconds and will power down the IMU between readings.
I'm interested to see if it starts communicating after being powered back up again.
Thank you for your help in exploring this,
Paul
#219553
Changed the log rate in seconds to 5
so after each line of data when viewed on a serial terminal (tera term)
there is a message displayed ICM-20948 failed to init.

I guess setting the log rate to 5 seconds puts it to sleep, but on waking from sleep it tries to wake up the IMU from sleep, but doesn't seem to want to wake up.
#219563
Hi Nick,
Thanks for trying that.
Unfortunately, it does look like you have a dead IMU. That should be impossible (the production test code does test the IMU) but you've tried everything I can think of.
I take it you bought your board through Mouser?
Thanks,
Paul
#219570
Thanks for reply, when I first tried the board it didn't recognise the GPS board so had to update to V 1.6 firmware and then it recognized the GPS.
I also tried 1.7 beta firmware, to see if that helped with the IMU but that didn't help.
I purchased from Mouser in the UK. I've placed order for another two boards to try from Mouser, I hope its just a one off and not a bad batch of boards they have in stock in the UK.

Thanks for advice, if it all works ok will look at getting the mux board and all the different sensor boards.
#219741
Thanks, just got two new boards which I updated to firmware 1.6 and IMU function ok on both boards, but am bit confused with the logging rate, in the hookup guide it mentions it can operate at a 250Hz rate, only have the IMU enabled, the serial and analogue logging are both disabled but can't set the unit to log IMU data at 250Hz rate, any advice appreciated.
#219743
Hi Nick,
The OLA needs a little persuasion to log that fast:
Use Menu 3 to disable any IMU readings you don't need. I guess you don't need to log temperature? Disabling that will help.
Use Menu 2 to disable the time stamp logging. That will help too.
Use Menu 1 to disable "Log to Terminal". I guess you don't need to see the data whizz up the screen?
Exit the menus. Let the OLA log the IMU data for a few seconds. The blue STAT LED should be lit up almost continuously.
Open Menu 1 again. Choose Option 4. The maximum value should now be in excess of 200 Hz.
The ultimate speed depends on the SD card. My OLA is currently running at 220Hz.
Best wishes,
Paul
#224513
Hi,

I'm dealing with the same issue, the only difference is that the non responsive IMU appears after updating the firmware to v1.9.

SD init failed (second attempt). Is card present? Formatted?
Config file read failed: SD offline
Artemis OpenLog v1.9
ICM-20948 failed to init.
SD card offline
Datalogging offline
Serial logging offline
IMU offline
Identifying Qwiic Devices...
No Qwiic devices detected

All IMU sensors are enabled. Before the update everything was working just fine.

Grateful if someone can help me to enable the IMU logging again.

Kind regards,

Joanie
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]