SparkFun Forums 

Where electronics enthusiasts find answers.

Hardware or product specific questions are best asked here.
#220954
Paul,
I purchased the following parts
1. SparkFun OpenLog Artemis (2)
2. Qwiic Cable - 500mm (2)
3. Qwiic Pressure/Humidity/Temp (PHT) Sensor - MS8607
4. Qwiic PT100 - ADS122C04
The OpenLog Artemis and Qwiic PT100 - ADS122C04 work fine.
Neither OpenLog Artemis recognizes the Qwiic Pressure/Humidity/Temp (PHT) Sensor - MS8607.
The terminal messages for the two OpenLogs when the MS8607 is connected (red power LED is on) are
Artemis OpenLog v1.5
Logging to: dataLog00011.TXT
Logging to: serialLog00020.TXT
SD card online
Data logging online
Serial logging online
IMU online
No Qwiic devices detected

Artemis OpenLog v1.7
Logging to: dataLog00012.TXT
Logging to: serialLog00020.TXT
SD card online
Data logging online
Serial logging online
IMU online
Identifying Qwiic Muxes...
Identifying Qwiic Devices...
No Qwiic devices detected

It is my understanding that the MS8607 should be automatically detected.
My question is – Should I see the MS8607 attached or do I have to change/add settings or commands? When I select
6) Detect / Configure Attached Devices
I get
Menu: Configure Attached Devices
**No devices detected on Qwiic bus**
1) Configure Qwiic Settings
x) Exit
Thank you,
Joe
User avatar
By PaulZC
#220965
Hi Joe,
I agree. Something strange is happening... The MS8607 should "just work" but I see that sometimes it is detected and sometimes isn't. Here's what I got on the first try with the default settings:

Artemis OpenLog v1.7
Logging to: dataLog00022.TXT
Finding the next available log file.
This could take a long time if the SD card contains many existing log files.
Logging to: serialLog00000.TXT
SD card online
Data logging online
Serial logging online
IMU online
Identifying Qwiic Muxes...
Identifying Qwiic Devices...
Autodetect complete
PHT-MS8607 online at address 0x40
rtcDate,rtcTime,aX,aY,aZ,gX,gY,gZ,mX,mY,mZ,imu_degC,humidity_%,hPa,degC,output_Hz,
01/01/2000,00:04:41.87,-142.58,-16.60,-1003.42,-0.38,-0.08,2.21,-20.70,23.55,-89.70,24.20,50.27,999.62,19.35,17.24,
01/01/2000,00:04:41.97,-154.30,-25.39,-1004.39,1.67,-1.37,1.58,-21.00,22.80,-88.95,24.34,50.27,999.67,19.45,12.35,

And then I tried again with the debug messages turned on (you can enable these through a hidden menu - type "d" from the main menu and the debug menu will appear):

Artemis OpenLog v1.7
Logging to: dataLog00024.TXT
Finding the next available log file.
This could take a long time if the SD card contains many existing log files.
Logging to: serialLog00000.TXT
SD card online
Data logging online
Serial logging online
IMU online
detectQwiicDevices started
Identifying Qwiic Muxes...
detectQwiicDevices: something detected at address 0x76
Identifying Qwiic Devices...
Autodetect complete
beginQwiicDevices: No devices detected
printOnlineDevice: No devices detected
rtcDate,rtcTime,aX,aY,aZ,gX,gY,gZ,mX,mY,mZ,imu_degC,output_Hz,
01/01/2000,00:09:28.75,-146.48,-12.21,-993.16,1.79,0.66,-0.34,-25.20,25.20,-90.45,24.10,333.33,
01/01/2000,00:09:28.85,-129.39,-10.74,-987.79,1.22,-1.59,-0.34,-24.15,25.20,-91.20,23.86,19.42,

The MS8607 is unique in that it appears as two I2C devices, one with address 0x40 and one with address 0x76. 0x76 is in the mux address range, so I wonder if it could be something to do with that? I shall need to investigate this... I've opened an Issue here:
https://github.com/sparkfun/OpenLog_Artemis/issues/54

Thanks for letting me know.
Very best wishes,
Paul
User avatar
By JD71
#221691
PaulZC wrote: Tue Dec 01, 2020 10:38 am Hi Joe,
Firmware version 1.8 has just gone live. You can find update instructions here:
https://github.com/sparkfun/OpenLog_Art ... UPGRADE.md
And the new binary file is here:
https://github.com/sparkfun/OpenLog_Art ... r/Binaries
Please let me know if this fixes the issue. I've tested it here - but you never know!
All the best,
Paul
Paul,
I loaded version 1.8 but the MS8607 still does not work as a Qwiic. It does work as an I2C sensor. I connected a SPX-16770/Qwiic PT100 to test the OpenLog Artemis and it works.

Thank you,

Joe
User avatar
By PaulZC
#221694
Hi Joe,
Can you please enable the debug messages - type "d" at the main menu to see the hidden debug menu.
Then please post all of the debug messages here so I can take a look. They should tell us what is going wrong.
Thank you,
Paul
User avatar
By JD71
#222037
Paulo,
Finally, I had a chance to test the MS8607
Summary:
Communication between OpenLog Artemis and MS8607 via Qwiic only works if another Qwiic device is attached to the MS8607. Conducted 4 trials with two OLA (I have 2 called OLA1 and OLA2), 1 MS8607 and 1 SPX-16770 with PT100 temperature sensor.
OpenLog Artemis
1. Trial #1 Using Tera Term
OLA1 connected with Qwiic to MS8607

Artemis OpenLog v1.8
Logging to: dataLog00164.TXT
Finding the next available log file.
This could take a long time if the SD card contains many existing log files.
Logging to: serialLog00000.TXT
SD card online
Data logging online
Serial logging online
IMU online
detectQwiicDevices started
Identifying Qwiic Muxes...
Identifying Qwiic Devices...
No Qwiic devices detected
rtcDate,rtcTime,aX,aY,aZ,gX,gY,gZ,mX,mY,mZ,imu_degC,output_Hz,
01/01/2000,00:04:16.26,-548.83,-165.53,-833.98,-2.34,0.05,-3.68,-18.45,-66.60,-19.65,25.25,250.00,
01/01/2000,00:04:16.36,-549.32,-157.71,-839.36,-0.88,-0.43,-2.15,-16.80,-66.00,-21.60,25.44,19.42,

2. Trial #2 Using Tera Term
OLA1 connected with Qwiic to MS8607 connected to SPX-16770 (Qwiic PT100 ADS122C04) with PT100

Artemis OpenLog v1.8
Logging to: dataLog00165.TXT
Finding the next available log file.
This could take a long time if the SD card contains many existing log files.
Logging to: serialLog00000.TXT
SD card online
Data logging online
Serial logging online
IMU online
detectQwiicDevices started
Identifying Qwiic Muxes...
detectQwiicDevices: something detected at address 0x76
detectQwiicDevices: MS8607/MS5637 found at address 0x76. Ignoring it for now...
Identifying Qwiic Devices...
detectQwiicDevices: something detected at address 0x40
detectQwiicDevices: added PHT-MS8607 at address 0x40
detectQwiicDevices: something detected at address 0x45
detectQwiicDevices: added ADC-ADS122C04 at address 0x45
detectQwiicDevices: something detected at address 0x76
Autodetect complete
beginQwiicDevices: attempting to begin deviceType PHT-MS8607 at address 0x40 using mux address 0x00 and port number 0
beginQwiicDevices: device is online
beginQwiicDevices: attempting to begin deviceType ADC-ADS122C04 at address 0x45 using mux address 0x00 and port number 0
beginQwiicDevices: device is online
PHT-MS8607 online at address 0x40
ADC-ADS122C04 online at address 0x45
Device count: 2
rtcDate,rtcTime,aX,aY,aZ,gX,gY,gZ,mX,mY,mZ,imu_degC,humidity_%,hPa,degC,degC,degC,output_Hz,
01/01/2000,00:25:32.86,-12.21,-144.04,-997.56,-1.40,0.89,-0.16,-24.15,-49.20,-

3. Trial #3 Using Tera Term
OLA2 connected with Qwiic to MS8607

Artemis OpenLog v1.8
Logging to: dataLog00167.TXT
Finding the next available log file.
This could take a long time if the SD card contains many existing log files.
Logging to: serialLog00000.TXT
SD card online
Data logging online
Serial logging online
IMU online
detectQwiicDevices started
Identifying Qwiic Muxes...
Identifying Qwiic Devices...
No Qwiic devices detected
rtcDate,rtcTime,aX,aY,aZ,gX,gY,gZ,mX,mY,mZ,imu_degC,output_Hz,
01/01/2000,00:00:17.47,556.64,-63.48,-833.01,-1.80,-4.37,3.33,-61.95,-28.20,-73.20,25.78,333.33,


4. Trial #4 Using Tera Term
OLA2 connected with Qwiic to MS8607 connected to SPX-16770 (Qwiic PT100 ADS122C04) with PT100


Artemis OpenLog v1.8
Logging to: dataLog00168.TXT
Finding the next available log file.
This could take a long time if the SD card contains many existing log files.
Logging to: serialLog00000.TXT
SD card online
Data logging online
Serial logging online
IMU online
detectQwiicDevices started
Identifying Qwiic Muxes...
detectQwiicDevices: something detected at address 0x76
detectQwiicDevices: MS8607/MS5637 found at address 0x76. Ignoring it for now...
Identifying Qwiic Devices...
detectQwiicDevices: something detected at address 0x40
detectQwiicDevices: added PHT-MS8607 at address 0x40
detectQwiicDevices: something detected at address 0x45
detectQwiicDevices: added ADC-ADS122C04 at address 0x45
detectQwiicDevices: something detected at address 0x76
Autodetect complete
beginQwiicDevices: attempting to begin deviceType PHT-MS8607 at address 0x40 using mux address 0x00 and port number 0
beginQwiicDevices: device is online
beginQwiicDevices: attempting to begin deviceType ADC-ADS122C04 at address 0x45 using mux address 0x00 and port number 0
beginQwiicDevices: device is online
PHT-MS8607 online at address 0x40
ADC-ADS122C04 online at address 0x45
Device count: 2
rtcDate,rtcTime,aX,aY,aZ,gX,gY,gZ,mX,mY,mZ,imu_degC,humidity_%,hPa,degC,degC,degC,output_Hz,
01/01/2000,00:03:27.55,463.38,-27.83,-890.14,2.25,-0.64,3.44,-53.85,-25.50,-87.00,26.83,33.23,985.75,23.36,22.858,22.094,5.68,
01/01/2000,00:03:27.78,469.73,-25.88,-899.41,1.80,0.85,2.05,-51.45,-23.40,-85.35,26.93,33.23,985.79,23.42,22.783,22.125,5.00,
01/01/2000,00:03:27.96,457.03,-32.71,-901.37,0.00,-0.17,2.01,-52.50,-25.65,-87.15,26.83,33.23,985.83,23.47,22.782,22.125,5.13,
01/01/2000,00:03:28.14,449.71,-43.95,-892.09,-1.08,-2.25,-0.62,-51.00,-22.20,-86.70,26.83,33.23,985.82,23.49,22.779,22.156,5.25,
01/01/2000,00:03:28.36,457.03,-27.34,-902.34,-2.68,0.57,-0.76,-51.60,-24.00,-87.00,26.93,33.23,985.80,23.48,22.784,22.156,5.11,
User avatar
By PaulZC
#222063
Hi Joe,
Many thanks for the diagnostics - that helps a lot.
I'll look at this as soon as I can. (There is another issue that needs solving too - misbehavior when connecting two MS8607s.)
Best wishes,
Paul
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]