SparkFun Forums 

Where electronics enthusiasts find answers.

Hardware or product specific questions are best asked here.
User avatar
By skyfly200
I saw recently that the support for BLE was added so I decided to pull out my Artemis Nano to try it out.
I have been having terrible luck uploading a sketch.

It initially was able to upload (I am using the ASB as the SVL was giving an error) the I2C sketch example, though I had to make some changes to get it to compile. Then it wouldn't connect to the serial port. Unplugging the board fixed this.
Then I was having a hard time uploading again. I tried just going back to the blink sketch. It would not upload, but eventually, after trying repeatedly it started to run blink even after no successful upload.
Now I can't get anything to upload after trying over and over. Tried the SVL again, tried different USB ports, resetting the Artemis and powering down and up with the PW-SW header. No luck.

I tried to bootload it then and I am getting this error in Arduino.'
Code: Select all
Arduino: 1.8.12 (Windows 10), Board: "RedBoard Artemis Nano, 921600, Ambiq Secure Bootloader (Advanced)"

	at cc.arduino.packages.uploaders.SerialUploader.burnBootloader(
Error while burning bootloader.
User avatar
By liquid.soulder
Thanks for reporting your issues, it is helpful for use to get an idea of what happens in the real world!

Hmmm. Usually java errors point to something going wrong within the Arduino IDE itself. That being said I find it unusual that your RedBoard Artemis Nano should have the ASB set to 921600 baud. In fact, this should not be a valid configuration. Is that listed in the lower right corner of Arduino or are you listing the SVL baud rate from the tools menu?

Right now the SVL is broken. Please stick with the ASB for the time being.

If you have any other comments we're happy to hear them!
User avatar
By skyfly200
It's set to use the ASB but yeah it has that baud rate setting from the SVL.

Thanks for your help @liquid.soulder
Just listened to the coffee chat with you as a guest yesterday and was inspired!
You do not have the required permissions to view the files attached to this post.
User avatar
By skyfly200
Still having an issue with this board and can't get anything to work.
I am kind of disapointed because this board and another ESP32 thing I got are both not woring and I have a very important project I want to apply them to.
I am considering getting the Artemis Dev Kit, but I am kind of discouraged by my experince with these sparkfun boards and I really cant afford to keed droping so much on boards that fail with me doing everything to get them to work.
I just havent had the best of luck since you moved to the forums from phone support.
User avatar
By pat.war
I am having similar results with my nano. I have the nano connected to a Garmin LIDAR LITE v4 via qwic cable to get distance measurements. It was working fine Saturday night on v1.2.0. I connected the nano to my android phone with a serial monitor app and it was looping and taking measurements awesomely. I then decided to take it to the next step and try to mess with the BLE. I installed version 2.0 and that's when it all came crashing down. All sorts of Java errors and now my nano is just dumping 1 line of garbage on the serial monitor. I hope it is not bricked. I see 2.0.1 has just been released I am going to try that and cross my fingers.
User avatar
By skyfly200
I am conmsidering just buying from Adafruit.
I havent had issues with their products in the past and their code is often more robust.
It sucks I have been a Sparkfun customer for nearly 7 years now and your company got me into learning electronics.
I live localy, have attended AVC and visted your headquarters. I have even met your CEO Nate.
I just want to be able to have my dev boards work, so I can focus on my projects unique challenges.
I paid for them already and a premium at that as I appreciate haveing the peace of mind. Please keep that a priority!!!
User avatar
By pat.war
I installed version 2.0.1. I was able to upload to the nano without issues but the serial communication from the nano is still messed up. I tried the Arduino IDE Serial monitor, putty and a Android serial monitor. No luck. I then removed version 2.0.1, deleted the 2.0 directory located at C:\Users\pcuser\AppData\Local\Arduino15\packages\SparkFun\hardware\apollo3. Then I installed version 1.2.0. Needless to say everything is back to normal. I am able to communicate with the nano via serial again and get measurements from the LIDAR.
User avatar
By skyfly200
Ok, I had a similar experience.
Installed v2.0.1 and was able to get it uploaded after retrying 5 times
Then the serial monitor was not connecting and dropping the connection if it did.
Is there another way I can develop with this right now that would be more reliable?
User avatar
By skyfly200
I tried reverting to 1.2.0 and can't upload any sketches,
now on a baud rate of 9600 I do get this from the device
Screenshot 2020-09-17 145445.png
You do not have the required permissions to view the files attached to this post.
User avatar
By pat.war
Did you remove the Sparkfun\hardware\apollo3 directory after removing version 2.0.1 in board manager? I had to remove 2.0.1 then delete the directory manually, because the removal in the Arduino IDE did not clean up the old 2.0 files. I then installed 1.2.0 in board manager. After that it worked again and serial port is stable. I will probably let version 2.x mature a bit before trying again.
User avatar
By rbulha
I'm using:
- Readboard Artemis Nano
- Arduino IDE 1.8.13

Few months before I've installed Apollo 3 core version 1.1.2 and manage to work on the LED example. Was really difficult code, but BLE was working fine.

September 30th I've heard that version 2.0.1 have added support to Arduino BLE so I jump right to trying this version.

My first sketch was basic LED just to compile the core and works. My second try was Arduino BLE LED example, but my first discovery was that the lib still reported as "NOT COMPATIBLE" inside the IDE.

But i've oppened the example anyway and for my suprise it compliles ('lot of warnnings") and downloads to the board. But nothing happens.

After check other people questions looks like the serial comunication is the issue. So I've comment the line:

while (!Serial);

This section makes the board waiting for the serial port be available to continue. And now the sketch is working.

 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]