SparkFun Forums 

Where electronics enthusiasts find answers.

Hardware or product specific questions are best asked here.
User avatar
By majd.shahin
#214077
Hallo , i am trying to program redboard artemis i just did every thing like Edge tutorial and adjust it for artemis but i got stacked at the last step by uploading the program

the last part of make file is

____________________________________________
wired_update: all ../../../../../tools/apollo3_scripts/create_cust_image_blob.py --bin $(CONFIG)/$(TARGET).bin --load-address 0xC000 --magic-num 0xCB -o $(CONFIG)/main_nonsecure_ota --version 0x0 ../../../../../tools/apollo3_scripts/create_cust_wireupdate_blob.py --load-address 0x20000 --bin $(CONFIG)/main_nonsecure_ota.bin -i 6 -o $(CONFIG)/main_nonsecure_wire --options 0x1

bootload: wired_update ../../../../../tools/apollo3_scripts/uart_wired_update.py -b 115200 $(serial) -r 1 -f $(CONFIG)/main_nonsecure_wire.bin -i 6

boot_artemis: wired_update ${ARTEMIS_LOADER_CMD} -b 115200 $(serial) -r 1 -f $(CONFIG)/main_nonsecure_wire.bin -i 6 -v
____________________________________________
but i got error

Connecting with Corvette over serial port /dev/ttyUSB0... Sending Hello. No response for command 0x00000000 Traceback (most recent call last): File "../../../../../tools/apollo3_scripts/uart_wired_update.py", line 345, in <module> main() File "../../../../../tools/apollo3_scripts/uart_wired_update.py", line 36, in main connect_device(ser) File "../../../../../tools/apollo3_scripts/uart_wired_update.py", line 56, in connect_device response = send_command(hello, 88, ser) File "../../../../../tools/apollo3_scripts/uart_wired_update.py", line 244, in send_command raise NoResponseError main.NoResponseError
_________________________________________
i can upload Arduino programs with the Arduino IDE,
and i tested the port with python and Arduino IDE, it works , but still get no response when i program it
is the problem in addresses or in somewhere else ?
User avatar
By liquid.soulder
#214131
Hmmm. I see that you've changed the bootload baud rate to 115200 - that should be correct for the Artemis modules. The artemis modules also have a slightly different configuration of the bootloader - the BOOT pin and polarity are different. However that should all be abstracted away by the hardware of your Redboard Artemis. So immediately I don't have a good idea of what is going wrong.

The tutorial that you are following is fairly outdated. We have created much better resources for working with the Apollo3 and Artemis modules. Have you tried any of these tools?
- Artemis Development Platform - a containerized development environment that runs in Docker. Contains all the following tools:
- SparkFun AmbiqSuite SDK - a copy of the AmbiqSuite SDK that contains the SparkFun BSPs by default
- SparkFun BSPs - Board support package for all the SparkFun boards (including the Edge)

All of those resources should have a getting started section in the README. If you have any questions about it or if you run into issues please let us know (replying here will be good).
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]