SparkFun Forums 

Where electronics enthusiasts find answers.

Hardware or product specific questions are best asked here.
User avatar
By Tuxedotshirt
#212817
I have tried changing the software serial pins in the example to 32,12 to correspond with the positions relative to the LTE board but none of the examples can start the LTE board. It works with an uno, I have the provider set up and can text to my phone. When I put the LTE board on top of the ATP, the software serial doesn't seem to be able to communicate with it. Is there something I'm missing? I read that all the I/O pins can be used for software serial.
#212819
Hello Tuxedotshirt.

We haven't tested this shield on the Artemis ATP before and it's possible that the example code and/or libraries won't work with it. We recommend using an Arduino Uno or a SparkFun RedBoard with this shield for best results.
User avatar
By Tuxedotshirt
#212820
I have tried starting Serial1 and setting the toggle on the LTE switch to hardware serial, but there is still no response from the LTE shield with the Artemis ATP. I have started Serial1 at 9600 and 115200, tried calling lte.begin(Serial1), lte.begin(Serial1, 115200) and lte.begin(Serial1, 9600) as well as lte.begin(lteSerial, 9600) with the rx and tx pins changed to 32,12 for the software serial in the example. No luck still. Maybe a logic level problem?
#212821
Maybe a logic level problem?
I don't think it's that, the shield is able to use the IOREF pin on the Artemis to set what logic levels to work at. Again, we haven't tested this shield on the Artemis, but I think it could be a incompatibility in our code or libraries.

If you're able to figure out what's causing the issue, please let us know but if you need a working setup quickly, I recommend using a Uno or ATmega328 based RedBoard like DEV-13975.
User avatar
By Tuxedotshirt
#212832
I got the ATP to recognize the LTE shield by powering my ATP from the computer, while the LTE board is on the charger with a lipo battery attached. It looks like the ATP can't power the LTE shield properly. The uno has no problem sending SMS and receiving Hologram messages without a battery. Weird.
Now I am having trouble sending Hologram messages like everyone else is. I can't find a definitive solution to this problem. It is disappointing that nobody I can see from SparkFun is working on a solution to support updates or make the uBlox software more accessible.
#227129
After several weeks of trying I managed to get the LTE board to work with the Artemis RedBoard over both hardware and software serial. I had to revert back to Sparkfun Apollo3 board manager v1.2.1. I know v2.1.1 doesn't work but haven't tried the others.

I don't really know why the newer version isn't working. In the LTE shield library there's a few Serial.print() commands in the sendCommandWithResponse() function. Uncommenting those lets you see the AT commands and responses from the SARA-R410M module. When using the newer version of the board manager about a third of the characters in the response get garbled, so its something to do with the serial communication I think. Problem seems to hold for both software and hardware serial.
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]