SparkFun Forums 

Where electronics enthusiasts find answers.

Hardware or product specific questions are best asked here.
User avatar
By exor674
#225925
Trying to use the expLoRaBLE with a Things Network Indoor Gateway (if relevant), using the example code from https://learn.sparkfun.com/tutorials/sp ... an-example.

I am able to see the data my expLoRaBLE is sending on the Things Network console, but am not able to send data back to the device.

As far as I can tell, the device is just immediately giving up during the RX windows:
Code: Select all
00:04:00.393: engineUpdate[opmode=0x888]
00:04:00.397: TX[mod=LoRa,sf=7,bw=125,cr=4/5,nocrc=0,ih=0,fcnt=12,freq=905.3,pow=21,len=17]: ...REDACTED...
Packet queued
15029275: EV_TXDONE
00:04:00.470: engineUpdate[opmode=0x888]
00:04:01.462: RX_MODE[mod=LoRa,sf=7,bw=500,cr=4/5,nocrc=1,ih=0,freq=927.5,rxtime=15091703]
00:04:01.476: WARNING: rxtime is 546 ticks in the past! (ramp-up time 5 ms / 368 ticks)
00:04:01.485: RX: TIMEOUT
00:04:02.466: RX_MODE[mod=LoRa,sf=12,bw=500,cr=4/5,nocrc=1,ih=0,freq=923.3,rxtime=15154451]
00:04:02.480: WARNING: rxtime is 548 ticks in the past! (ramp-up time 5 ms / 365 ticks)
00:04:02.537: RX: TIMEOUT
15267436: EV_TXCOMPLETE (includes waiting for RX windows)
I'd imagine that warning is why RX isn't working. I do see the commented-out "LMIC_setClockError" in the example, but neither that nor MAX_CLOCK_ERROR seem to exist.

Any pointers in getting this to work?

I'd also like to get OTAA working, but I can't figure out how to restrict the OTAA to only The Things Network subband (and also RX isn't working, so I can't activate).

Thanks.

In case it is for some reason relevant, I am using https://www.sparkfun.com/products/17841 for the antenna.
User avatar
By jmjo
#226505
I had the same problem. I changed the RX_RAMPUP in oslmic.h value and got rid of the warning.
From 5000 went to 15000. Did not work any better but the warning is gone.
Maybe someone could answer if this is reasonable to change the value?!.
The problem with ExpLoraBle is the follow-up. Nobody answer to any of your questions and not only the functionning is worse quality as bad reception and transmission and not too much info.
Using other products with far much better success and quality.
Too bad it sounded to be a nice solution...
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]