SparkFun Forums 

Where electronics enthusiasts find answers.

Hardware or product specific questions are best asked here.
User avatar
By Baldurk
#212767
Hi there,
I just bought myself the RedBoard Artemis along with various Qwiic modules for a project but when I was going to start changing I2C addresses for two Qwiic Buttons, the board had trouble reading the I2C bus.
Using the I2C scanner sketch the board reads a device on every address.
The problem seems to be the ReadBoard since I swapped it out for an Arduino Due and that worked as expected.
This is similar to reading an I2C bus without pull-up resistors but since this is the Qwiic system, that can't be the problem can it?
Can someone help me with this?
Thanks
#213281
Hi Baldurk,

Out of curiousity, what SVL Baud Rate did you use to program the RedBoard Artemis?

I experienced this exact same problem yesterday when trying to connect I2C devices to my Artemis Nano. I ran the same I2C Scanner sketch and no I2C devices were detected. I then realized I had unknowingly left the SVL Baud Rate at the default of 921600. As soon as I changed this to 115200 and re-uploaded the sketch, my I2C devices were detected.

Hopefully this helps!

Cheers,
Adam
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum