SparkFun Forums 

Where electronics enthusiasts find answers.

What are we doing right with Artemis? What are we doing wrong? Let us know here!
User avatar
By winhaven
#224805
Hi,

I got a RedBoard Artemis ATP to start developing for a project. The peripherals I want to use are a 9" display from 4D Systems plus a few qwiic sensors.

I can run everything fine off of the USB-C connector on the RedBoard.
If I try to run things using a 12V supply connected to the RedBoard, the power converter chip gets quite hot.
If I unplug the display from the board, it runs cool.

According to the 4D docs, the display should be drawing 500-600mA

Is this expected?

Thanks!
User avatar
By TS-Chris
#224806
Yep, that's normal.
The more voltage you need to drop in the regulator and current you're putting through it, the hotter it's going to run.
Dropping down to 7 volts would be recommended to keep things running cool.
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]