SparkFun Forums 

Where electronics enthusiasts find answers.

Tips, tricks, & best best practices using Artemis with your board designs.
User avatar
By strikervvv
#244484
Hello, due to some problems with the code, I decided to clean up my old files by manually opening the SD card and deleting the old datalog files. I've done this once, and the Artemis worked perfectly fine afterward, and the SD card logged the data properly; however, this time, the SD card seems to be unable to connect to and log the data. I do not know if this is related, but the Artemis used to flash red and blue when powered on, but now it only flashes the red LED. Does anyone know how I can fix my SD card or what files to add back to my SD card if I deleted something I shouldn't have? (I believe it is an SD card problem, but I may be wrong) Thank you.
User avatar
By LillianFelly
#244619
Here are some files that you may need to add back to your SD card if you deleted them:

config.json: This file contains configuration settings for the Artemis.
firmware.bin: This file contains the firmware for the Artemis.
datalog.txt: This file is where the Artemis logs its data.
If you're not sure which files to add back, you can try contacting the Artemis support team for help.

As for the red flashing LED, that usually indicates that the Artemis is in boot mode. If the Artemis is not booting up properly, it could be because of a problem with the SD card, or it could be because of a problem with the Artemis itself. If you've tried all of the above and the Artemis is still not booting up properly, you may need to contact the Artemis support team for help.

Here are some additional tips for troubleshooting SD card problems:

Make sure that the SD card is inserted correctly into the Artemis.
Try cleaning the SD card with a cotton swab and some alcohol.
Try using a different SD card reader.
Try connecting the Artemis to a different computer.
User avatar
By BrovtalGemini
#245137
It sounds like you may have accidentally deleted some critical files from the SD card, which is preventing the Artemis from logging data properly. The flashing red LED on power-up suggests a problem with the SD card or the files on it.

To troubleshoot the issue, follow these steps:

Check the SD card format: Make sure the SD card is formatted as FAT32. If it's not, reformat it using a reliable SD card formatting tool.

Verify the SD card integrity: Use an SD card checker tool to scan the SD card for errors or corruption. If any errors are found, replace the SD card.

Restore backup files: If you have a backup of the SD card contents, try restoring it to see if that resolves the issue.

Reinstall Artemis firmware: If the SD card appears to be healthy, try reinstalling the Artemis firmware. This will ensure that the necessary files are present for proper operation.

Check for file permissions: Ensure that the Artemis has proper read and write permissions for the SD card.

Inspect the SD card reader: Check the SD card reader for any physical damage or debris that might be causing connection issues.

Use a different SD card: Try using a different SD card to rule out any issues with the specific card you're using.

If none of these steps resolve the issue, it might be a hardware problem with the Artemis board itself. In that case, you may need to contact the manufacturer for further assistance.
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum