SparkFun Forums 

Where electronics enthusiasts find answers.

Tips, tricks, & best best practices using Artemis with your board designs.
#230679
Hi all again. Doing a circuit analysis on the Bootloader Reset Circuit, and it appears that when RESET is driven low, the BOOT bus voltage goes negative (-3V). Here's my understanding: the side of the .1uF capacitor between BOOT and the rest of the circuit is normally held around 3V due to pull up resistor. But when RESET is driven low, this side of the cap drops to 0V, and the BOOT side of the cap consequently drops to -3V temporarily, exposing the Artemis/Apollo Boot pin to negative voltage.

My question is, does this pose any problems for the Artemis/Apollo, assuming my analysis is correct? I can't find anywhere in the datasheet https://ambiq.com/wp-content/uploads/20 ... asheet.pdf that says negative voltage is OK. And if it poses a problem, why not place a diode there, perhaps?

Here's I simulation tool I used to verify my analysis: https://www.falstad.com/circuit/circuit ... Yq-Ua+UxAA

Thanks for the help!!
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]