SparkFun Forums 

Where electronics enthusiasts find answers.

Tips and questions relating to the GPS modules from SFE
By Robert Mann
#26377
I purchased this with the USB board. I can receive GPS information using the AT commands and I can call the phone number and it picks up with the ATA command and the status line goes solid green. The status light is blinking slowly and a AT#MONI returns the Cingular information. I did issue the AT#BND=1 and like I said incoming calls work but outgoing I get a NO CARRIER. I get the same thing when trying to access SMS or the GPRS.

Do you have to call Cingular and get something switched or get the GPRS username and password or how does that all work. I have been all over the DOCS and have even updated the firmware to the latest version.

I have searched this forum but unless I am searching for the wrong thing I can't find anything here to help.

Any ideas?
By cabbage
#26379
What commands are you sending to make the outgoing call?
By Robert Mann
#26382
ATA16615551212

With 5551212 being a real number.
By jasonharper
#26385
ATA is used for answering calls. I think you want ATD for placing one.
By Robert Mann
#26388
Oh sorry ATD is what I did use but that is when I get the NO CARRIER
I partially got GPRS to work now. But it takes a long time to do anything and ends up timing out before I can really do anything.
By rileonar
#26875
I have exactly the same problem:

- outgoing voice calls give NO CONNECT
- incoming calls are OK
- outgoing SMS are OK
- outgoing data calls give NO CONNECT

There is enough signal (-68dbm), the device is registered to the network, I tried with different SIM from different GSM providers, also tried using numbers from SIM or modem Phonebook: no luck.

Any hints?

TIA.
By mobiliare
#28418
have you sorted this out?
Even 'm facing the same problem; Neither 'm able to an inbound/outbound call using the module?

Could see good signal strength from cingular on doing a AT#MONI
By maokh
#28442
Try:

ATD15551212;

you will need the semi-colon to tell it to use voice, otherwise, you will need to go through an extensive AT command sequence to make it default to this.
By rileonar
#28453
At last I solved the problem! :D

In my situation the problem was caused by a timeout too short. I try to explain...
My application send the ATD command then waits for the OK response.
If the response doesn't come before the timeout, then the application try to close the call... but if you send any character through the serial BEFORE the OK, the module aborts the call and answer "NO CARRIER".
This behaviour is quite funny, but it can be easily replicated (even manually with Hyperterminal or similar).

Someone from Telit confirmed me that is not allowed to send more characters/commands during call setup (maybe I missed it, but this rule is not present in manuals :evil: )
By maokh
#28534
That would do it too :)

You will find a lot of neat "features" within the telit module....
By deelip_prusty
#34332
Hi friend ....

i am also getting NO CARRIER as output when am executing GET / HTTP/1.1<cr><lf> after getting CONNECT indication from command

AT#SKTD=0,80,"www.telit.com",0,0

hav u any solution for this.. how did u manage it?
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]