SparkFun Forums 

Where electronics enthusiasts find answers.

Tips and questions relating to the GPS modules from SFE
By koza
#188783
Hello SparkFun Colleagues!

I am to-be-happy owner of Venus638FLPx-L.

Facts:
- Using Raspberry pi, Tx from RPI connected to Rx of GPS and vice versa.
- Module powered up with 3.3V
- EMEIA data is coming fine from Venus (for example with command: cat /dev/ttyAMA0)

I would like to change baud rate, update rate etc. So I am trying to send the commands to the devices, however, regardless what I send, I am getting 0x84 (NACK) information.

Simplest possible example (from Linux terminal, similar story when I send commands from C), asking the device to move into binary mode:
Code: Select all
echo -e "\xA0\xA1\x00\x03\x09\x02\x00\x0B\x0D\x0A" > /dev/ttyAMA0
Answer I am getting (the answer is somewhere between EMEIA data):
Code: Select all
A0 A1 02 84 09 8D 0A 0A
(please note that the answer doesn't come in [...] 0x0D, 0x0A format...)

I am getting similar answers when trying other commands, like getting device info (0x02).

Question is:
What I am doing wrong that Venus doesn't want to reply with ACK and execute the command?

Greetings,
Koza
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]