SparkFun Forums 

Where electronics enthusiasts find answers.

Tips and questions relating to the GPS modules from SFE
By asp128
I have connected my Mediatek MT3329 GPS unit to a serial to USB converter
On the serial terminal it is showing a string '00 00 00' in succession in hex mode, there is no output when i switch to text mode
I have tried changing the baud rate but it is still not showing the NMEA string
GPS has not acquired fix since I'm indoors, but shouldn't it generate an NMEA string?
What could be the possible reasons??
By fll-freak
What is the exact product you are using? A link to the product page would be nice.

Have you accounted for serial voltage levels? The GPS may not produce RS-232 but only logic level 0signals. You may need to provide a circuit to do that before your USB to RS-232 adapter would work. Conversely, if you have a USB to logic level (3V3 ot 5V0) converter and the GPS is sending out true RS-232 it would not work as well.

Again, the exact model you are trying to use is needed to comment.
By fll-freak
From the datasheet, this device runs on 3 to 5V and its serial output is logic level. This means one of two things.
1) You will need to convert to and from logic level to RS-232 before using an RS-232 to USB dongle.
2) You will need to use the appropriate voltage logic level to USB cable (like the Sparkfun FTDI cable).

This part also has a 3D fix pin. Have you looked to see its state? With no fix it alternates between high and low voltage every second. With a 3D fix, it goes low 24/7.
By VBala
I have a USB GPS dongle with MT3329 chipset that works fine on Win XP PC after installing Virtual ComPort driver. NMEA sentences are received and gets lock and I get correct Lat & Long

My aim is to connect this to my 4.1.1 Jellybean Android tablet through USB OTG port.

The schematic for the dongle is ... _v1_01.pdf

What I am not clear are

1) As it works fine with the USB port on PC, I do not require any converter. Is that correct?

2) I come across terms for serial converters like PL2303 and FTDI etc. Which serial converter does MT3329 use?

3) What is the equivalent of Windows Virtual COM port driver in Android world? I tried with USB4GPSHoneycomb_alpha. But though USB GPS services get started I do not see anything under /tty/USB

4) Tried with SLickdevlabs app too. But does not work. I do not get NMEA sentences on my Android tablet.

What should I do get it working?