SparkFun Forums 

Where electronics enthusiasts find answers.

Tips and questions relating to the GPS modules from SFE
By kazansky
#133020
Hi everyone
I'm using the frontend SiGE GN3S sampler (ver. 2) on Ubuntu 10.10 (fresh install), and fx2-programmer to flash some firmware on the FE. After a few try, the frontend just disappear from lsusb, and I can't do anything with that since then. I also tried it on win 7 (which result in code 43) and win XP (which also failed), and couldn't even install the driver for it.

This is what happened:
1. I plugged in the FE in Ubuntu 10.10, run lsusb in terminal, it says my FE has VID=0x1781, PID=0x0b39, vendor name is "Multiple vendors"
2. I tried running make program with fx2-programmer:
Code: Select all
program:
	./fx2-programmer $(VID) $(PID) set 0xE600 1
	./fx2-programmer $(VID) $(PID) program $(FW_PATH)gn3s_firmware.ihx
	./fx2-programmer $(VID) $(PID) set 0xE600 0
and it failed on the first command:
Code: Select all
kazansky@kaz-ubuntu:~/GNSS/gn3s-linux/gn3s-linux/bin$ make program
./fx2-programmer 0x1781 0x0b39 set 0xE600 0
make: execvp: ./fx2-programmer: Permission denied
make: *** [program] Error 127
I tried that command several times, with different VID and PID, and all failed.
3. I disconnect the module, then plugged in again. This time the module didn't show up on lsusb. No "multiple vendor", no 0x1781,... nothing, like it weren't even there.

I couldn't do anything to "talk" to the FE since then, as all I've got is the USB connection.

What should I do to make it normal again? Please help! Thank you all very much!

PS: I'm sorry for my bad English
#134080
>kazansky@kaz-ubuntu:~/GNSS/gn3s-linux/gn3s-linux/bin$ make program
>./fx2-programmer 0x1781 0x0b39 set 0xE600 0
>make: execvp: ./fx2-programmer: Permission denied
>make: *** [program] Error 127

you need to use sudo to get permission to program your device
sudo ./fx2-programmer 0x1781 0x0b39 set 0xE600 0