SparkFun Forums 

Where electronics enthusiasts find answers.

Tips and questions relating to the GPS modules from SFE
By lewie.catt

i am currently using one of your gps receivers for my final years university project.
when i am using u-center, i have configured the device to only send GPGLL stings. which is what i want.
each time i power off the device, then supply power to it again it returns to the default setting sending multiple types of data.

i have referred to the U-Center user guide, along with reading online forums, all to no prevail.

i have tried in configuration view - CFG- selecting save current configuration. then on the bottom left corner clicking send.

secondly i have tried tools-GPS Configuration- checked 'store configuraton intoBBR/Flash (non-volatile memory)'-then saved as a file.

i am currently stumped, and effectively has stalled the progress of my project.

i would be grateful for any help that you could offer.

regards lewie
By fll-freak
lewie.catt wrote:i am currently using one of your gps receivers...

I can't help you directly, but you should know that these forums are not a direct path to talk to Sparkfun technical support. You are in fact talking to their customers who tend to help each other.

If you want to contact Sparkfun tech support, visit their webpage and find the appropriate email address to use. Although if you give this question a few days, I suspect someone will help you out.
By BigRedBee
Which u-blox GPS module are you using? Not all of the modules have on-board flash memory to store parameters through a cold boot.

-- Greg
By lewie.catt
hi greg,

i am using the D2523T sparkfun module h ... ducts/9566

the u-blox chip is the UBX-G5010 ... 06042).pdf

when i have the chip connected, the changes i make are succesfully sent to the chip and the chip's output is only GPGLL which is what i want. then i save it.

remove power, re-supply power and the change i have made are gone and back to default.

i hope you can help me, as like i said its for university and i am a lil stressed.

regards lewie
By BigRedBee
I do not believe that the 5010 has any internal flash memory. So, you have to reconfig it every time you apply power. Same thing is true for the NEQ-6Q version that I am using.