SparkFun Forums 

Where electronics enthusiasts find answers.

Tips and questions relating to the GPS modules from SFE
By mjoppich
#130682
Hello,

I got that LS20031 from my Sparkfun distributor.

Everything worked well and I already once got the correct position.

However now I get a completely wrong position. It's way off by some kilometers!

Checksum is correct, so i think is no serial communication error.

Anyone who is able to help?

The received position is

50.78041,6.062213

where it should be around this:

50.462816 6.036838 .

Hope someone can help!

Markus
#130688
I am assuming the indicator in the NMEA string indicates a locked solution?

Have you ever turned on the GPS at the wrong location? Could it have cached that position in some strange mode?

Did you change the Datum (if that is possible on this unit?) from WGS-84? Some datums can be hundreds of meters different than WGS-84.
#130701
hi, and thanks for the reply!

no, i've never been to that place. possibly the gps also not.

yes, the NMEA string says it's a valid position and the led is flashing every second.

circuiting the battery seems to solve the problem, but is not what i want to do too often :S

i did not change the datum by myself actively, but will have a look!

markus
#130713
unfortunately the battery (or better rechargeable battery) is soldered onto the board (whoever thought that would anything better -.-). i read on the board that this would reset the gps to factory settings.

it just happens on a random basis (i think). It happened already two times today, though I must admit I'm using the unit every minute as I am still working on that project.
#130717
You will need to try to isolate when it happens. Are you programing the board just before? Do you get a static shock? Perhaps you rebooted a computer? Or perhaps in the shade of a tree?

Have you tried to wait several minutes to see if it fixes itself? How about moving it a few hundred meters and see if it changes its position by the right amount?