SparkFun Forums 

Where electronics enthusiasts find answers.

Tips and questions relating to the GPS modules from SFE
By EricAtPobot

I'm using a GARMIN 35 OEM serial GPS (mouse style with embedded antenna and RS232 interface). This kind of device is commonly used in fleet tracking applications (this one has been generously donated by one of our suppliers, and had a "Volvo" label on it :wink:).

The project has nothing to do with this context, since it's intended for educational projects related to environment and such. For French speaking people, you can find more details here : Sorry for the others, but as you may know it's already quite a huge work to document and I've no time left for translation for the moment. Anyway, you'll find there a lot of illustrations and pictures in the articles which can give an idea of what all this is about.

Although the unit has worked properly at the beginning, since recently, all the GPRMC messages indicate not validated coordinates ('V' status instead of 'A' one). The GPS is used in the exact same conditions (same room, same environment,...). The only thing is that I've not worked on it for a long period (several months) since the time it worked fine.

Would anybody has some suggestion about the possible reasons, and remedies if any ?

Many thanks in advance and best regards.
User avatar
By leon_heller
Try it outside. Something in the vicinity might now be interfering with the signal.

By Polux rsv
Does it contain a backup battery? It could be discharged.

By EricAtPobot
@Leon: I'll do it. I can't see anything that is different now than during the first tests, but you're right.

@Polux: Is there a way to check this ? And what can I do if it is the case ?

Thanks to both of you for your support.

Best regards
By TomasTrek
I have an MTK GPS which will spend about 20 minutes searching the sky if it is not used in 6 months, and I get V instead of A until it decides it has done enough scanning. I dont know about the device you have but it could be doing the same, try leaving it outside with good sky view for an hour or so and then taking a reading from it.
By EricAtPobot
Thanks everybody for your suggestions. I've solved my problem :)

In fact, the culprit was (once again) Murphy. But this time, the Murphy's rule worked in reverse : it made something work although it should not.

More clearly now :wink: As suggested, I've tried outside, and then the GPS generated valid coordinates after a handful of seconds only. So it is still working fine, and it was a problem of signal quality.

What sent me on the wrong direction is the fact that, despite it was in my workshop inside the house, it worked fine the first time I tried it, although it shouldn't. So when it didn't work during my latest experiments, I was not thinking at all it could be the problem.

Best regards and thanks again.