SparkFun Forums 

Where electronics enthusiasts find answers.

Tips and questions relating to the GPS modules from SFE
By rtxo
Hi Folks--I've tried running the et-102 with NTP (network
time protocol) with pretty dismal performance in NMEA
mode. I used the gpsd code's sirfmon utility to check
out the functionality of the et-102 with my unix PC's
(I built a MAX232 to buffer the TTL with RS-232 levels).
The sirfmon is excellent, by the way--it shows the
et-102 grabbing SBAS style DGPS off a geostationary
satellite here in California.

Anyways, setting up only the $GPGGA sentence and
running ntp shows that the NMEA code out of the
et-102 will flap back and forth a whole second.


Utterly unusable with ntp. If it were entirely one second off,
consistently, that could be "fudged" in ntp. But, the
NMEA sentence just wanders back and forth, making
it basically unusable. On the other hand, the PPS output
is very useable. I set up the ATOM driver in ntp and
made a host with a Garmin GPS35/ntp the "prefer" host
and when ntp got sync, the ATOM kicked in and the
pps shows within single digits of microsecond, on par with
the gps35's PPS output in ntp.

I also tried setting the $GPRMC sentence with no
improvement. The NMEA mode just bites mouldy
burritos. Unless... Is there a firmware update available
for this thing? The ones I have show: