SparkFun Forums 

Where electronics enthusiasts find answers.

Tips and questions relating to the GPS modules from SFE
By martin
I've bought a GM862-GPS module and breakout board. Everything worked all right in the beginning.

I used Hyperterminal to connect to the serial port. All AT commands returned OK. After inserting a SIM card I could place a data call by using ATD. I was also able to upload a python script using AT#WSCRIPT.

After a while the serial port did not respond anymore. The output became completely unreadable. I already tried different baud settings in Hyperterminal. However, when I connect the RS232 RX-line to the module TX_GPS Pin 35 and change baud rate to 4800, then I receive NMEA sentences perfectly readable.

What is going wrong? Why cannot I connect to the serial port anymore?

The module is powered through a 3,7 V Li-Po battery. The module TX- and RX-lines are connected to a MAX232. Between the GM862 TX-line and the MAX232 is a 4,7k ohm / 6,8k ohm resistor voltage divider in order to bring the 5V down to 3V, which is within the operating range for 2,8V CMOS. The MAX232 is connected to the RS232/DB9 port on the PC.

The Status LED flashes fast after turning the module on. When the SIM card is inserted, then after some seconds the LED is flashing slow. But the serial port output is always unreadable, regardless if the SIM card is inserted or not.

Just when I power on the module, then I can type AT commands in Hyperterminal and receive OK. But a few seconds later the output becomes unreadable. When I turn the module off and then on again, the same thing. The module responds OK only for a few seconds.
User avatar
By leon_heller
Do you have a low ESR 100 uF capacitor across the supply pins, as close as possible to the module?

By martin
I did not have a capacitor at the Li-Po battery power supply in the first place, but now I do. The result is still the same. The serial port responds to AT commands a few seconds after powering on the module and then it dies. Thereafter the port randomly transmits unreadable characters.
User avatar
By leon_heller
Is it the correct capacitor type and is it directly across the pins?

By martin
I just solved the problem. It turned out that the python script did not run properly.

Within the two seconds after powering on the module I typed the command AT#ESCRIPT="". Turning off/on the module, and it is up and running as a charm.

The python scripts are taken from this post but I probably need to check them.

I actually want the GM862-GPS to send a SMS containing the current position in response to an incoming SMS.