SparkFun Forums 

Where electronics enthusiasts find answers.

Topics pertaining to the Arduino Core & software used with the Artemis module and Artemis development boards.

I am transmitting using the Iridium modem and have an issue.

My code is based on the A Better Tracker example by Paul Clark, see ... balTracker

The modem will transmit and after some transmits, it will send the error

Transmission failed with error code 3

and also

***modem.clearBuffers failed with error 3***

When it tries to transmit anytime after these errors it will give

***modem.begin failed with error 5***

Any clue as to why this could be happening?


I tested the example15_BetterTracker ( ... terTracker)

The only change was on line 82:
#define DEF_TXINT 5// DEFault TX INTerval (Minutes)

Instead of 5 I used 130

The same issue: Sending messages, then:
Transmission failed with error code 3
Clearing the MO buffer.
*** modem.clearBuffers failed with error 3 ***
Putting the 9603N to sleep.

And after this all messages show:
Starting modem...
*** modem.begin failed with error 5 ***
Getting ready to put the Apollo3 into deep sleep...
TS-Russell wrote: Wed May 22, 2024 4:08 pm Do the example codes behave the same? (do they throw the same error after x messages?) Test it using the default sketches and circle back
Yes they do. The only change was the transmission delay (I was using 140 minutes). Same errors: first error code 3 and then error code 5. I tried resetting the rx before waking the modem, and still had the same issue. It is also not deterministic: sometimes it takes a while (more than 10 send attempts (either successful or unsuccessful)) to get to error 3, while other times it happens in the third attempt.
TS-Russell wrote: Wed Jun 05, 2024 3:31 pm Maybe try clearing the buffers more often? Can you send smaller messages more often?
Are you using the additional supercapacitors? ... e-assembly
I tried clearing the and re defining the modem class, clearing the rx multiple times. I was using supercapacitors and had the same problem, removed them and the problem persists. If send more often I have not had the issue, but have not tested extensively (because it could be expensive). When I reset the controller everything works fine again, so maybe it is not a hardware problem... my current workaround is to perform a software reset and catch it during init so it will not repeat unwanted instructions... but it is not ideal.
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum