SparkFun Forums 

Where electronics enthusiasts find answers.

Topics pertaining to the Arduino Core & software used with the Artemis module and Artemis development boards.
User avatar
By collink
I just purchased an Artemis ATP recently, and even after installing the drivers. At first, I thought it was defective because I was plugging it into a USB 3.2 (type A) port. Eventually I had the idea to try plugging it into my work M1 MacBook Pro (which only has type C ports), and to my surprise it was detected. I went back and plugged it into the type C port on my Win11 PC and it was recognized there as well. I can't think of a technical reason why it shouldn't also work on type A ports with a A-to-C cable, but I suppose there could be one.

Is this expected behavior?
User avatar
By TS-Russell
My first guess would be that maybe the a->c cable doesn't have data lines? I've experienced the same thing and it turned out the cable I was using only had power wires on the usb (charging cable only)
User avatar
By collink
That was my first instinct as well, so I tried it with one which I presently use to connect an Xbox Elite 2 controller, so it's known good. Same result, unfortunately.

I'm not terribly concerned about not being able to program it without using a C-to-C cable, but I want to use it to run a button box for sim racing, and I have a USB 3 hub on my rig that I was banking on plugging it into, which doesn't have any type C ports.
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum