SparkFun Forums 

Where electronics enthusiasts find answers.

Topics pertaining to the Arduino Core & software used with the Artemis module and Artemis development boards.
User avatar
By krswinney
#222253
I have experience using arduino but not with bluetooth. I bought an artemis redboard to drive an Evil Mad Scientist Simple Relay shield.

I believe I was able to download the appropriate addon since I could modify the blink example to turn the relay off an on.

My goal is to be able to turn the relay off and on with an app on my phone. I downloaded the Arduin0BLE library but have not been able to decipher how to connect to the artemis. In a topic on this forum I saw references to version a version 2.0 library, but the only one I could find through the IDE's Library Manage was 1.2.

Need some advice on where to look for help next.
Ken
User avatar
By krswinney
#222277
That is the tutorial I have been following.
I installed the Sparkfun Apollo3 Boards 1.2.1 board definitions by using the Arduino IDE Boards manager, but there is no version 2.0 listed. I am using version 1.8.13 of the IDE. I just noticed the note about only being compatible with version up to 1.8.12...so I am going to back up and install version 1.8.12 and see if that helps.
User avatar
By krswinney
#222278
I uninstalled 1.8.13 and tried 11 and 12, but still does not give me an option for version 2.0 on the Apollo boards... I must be doing something really stupid. Still stuck.
User avatar
By KHE
#222279
From the Aarduino IDE, choose File | Preferences

click the little box to the right of Additional Boards Manager URL's: (a list box will pop up)

go to the end of the line or the end of the last line if you have several lines and hit return to add a new line...

Copy this next line and paste it into that list box. Click OK. Exit Arduino and then re-start it. Now when you got to Boards Manager you should see the 2.0...cores

https://raw.githubusercontent.com/spark ... index.json
User avatar
By krswinney
#222312
Thank you I was not able to get the 2.0.3 version of the Apollo3 Boards installed. But when I try to compile the Blink example from the examples>incompatible>ArdinoBLE>peripherals>LED I get an error message that it cannot find
Swinney\AppData \Arduino15\packages\Sparkfun\hardware\apollo3\2.03\variants\SFE_ARTEMIS/mbed/mbed_config.h

I am assuming that these files were supposed to be downloaded when I did installed the apollo3 using the Boards Manager. Where are these files typically installed? Is away to change the search path the Arduino IDE is using? (hope these questions are making sense)
I can find the ArudinoBLE library, but not any directories identified as apollo3.
By paulvha
#222320
These files would all have been installed when the installation instructions are followed. Best for now :

close down IDE
remove the folder 2.0.3 in Swinney\AppData \Arduino15\packages\Sparkfun\hardware\apollo3\.
Restart IDE
Boards manager
look for apollo3 and install the 2.0.3 version
Select the right board in the IDE
recompile
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]