SparkFun Forums 

Where electronics enthusiasts find answers.

Everything with the AmbiqSuite SDK tools and software are welcome here.
User avatar
By rowanham
I apologize if this is not the right forum for this question.
I am building a tool involving a python host app running on Ubuntu, and an Artemis MicroMod mounted on a main board double. The two exchange commands and data over the UART serial interface with JSON. My high level problem right now is that I can read data from the UART in my host side Python app, but I can't write from the host to the target. I'm using a unicode class that inherits from pyserial and has worked for me with FTDI serial chips in the past. Is there anything I should know about writing to the Artemis UART from Python?

User avatar
By TS-Russell
Is it working normally outside of your app? (can you transmit data to it using another device?)

I'd say take a look at the Pin section here ... e-overview and compare/contrast that with the Mainboard Double's to ensure there isn't a pin conflict? Also go through the artemis' docs and see if RTS/CTS is/isn't required
User avatar
By rowanham
Thanks for the pointers.
I can type characters in minicom and read them on the target side, so that much works
I read the pinout documentation for the main board double and the artermis micro mod, and that has left me really confused. The main board doc seems to say it supports two UART interfaces, only one of which supports flow control. On the other hand, the Artermis micro mod doc says that board only supports one UART, and it has flow control. So I tried to correlate this information with what I found in the BSP I've been using (the Ambiq SDK with the Spark Fun special sauce). As far as I can tell, the BSP says the TX and RX pins I've been using are "48" and "49", but I don't know what these numbers mean. (They don't seem to correspond to any pin numbers I can find.)
Some caveats:
1) My main board double seems to be and early revision. I think it is v1.1 (if that is a meaningful version number).
2) The Artemis Micro Mod doc says the one UART that is wired out includes CTS/RTS. I've not been using flow control, so maybe it is time I learned how that works...
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum