SparkFun Forums 

Where electronics enthusiasts find answers.

Everything with the AmbiqSuite SDK tools and software are welcome here.
User avatar
By hanumanx
#235056
Hi,
I've been trying to use the Artemis Nano with its BLE featues and my Android Q (Samsung Galaxy S9) with various examples with no luck. I've tried the amdtp, the BLE Blink LED example, I've even built my own makefile with a Tag profile. Nothing works.
1. Whenever I'm trying to scan for devices, I get no results [Android: btAdapter.getBluetoothLeScanner().startScan()].
2. I sometime manage to see the device when I scan them using the phone's Bluetooth scanning menu but it only pairs.
3. Using the nRF app I'm trying to connect to it [Android: myBLEDevice.connectGatt()] but getting error message 257 and "Device disconnected"
Is it Android Q's fault? Something incompatible here? Anyone had these kind of issues?
Thanks!!
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]