SparkFun Forums 

Where electronics enthusiasts find answers.

Everything with the AmbiqSuite SDK tools and software are welcome here.
User avatar
By Malkovich
#223369
Attempting to compile new project for Artemis using Visual Micro on Visual Studio (VS) 2019. Project compiles just fine using Arduino IDE. But, in VS, I get errors:

Error linking for board Artemis
CommonAnalog.cpp: 163: multiple definition of indexTone (unsigned char, unsigned int, unsigned long); C \ Users \ klsor \ AppData \ Local \ Temp \ VMBuilds \ myArduinoProj \ SparkFun_sfe_artemis \ Rele
ase \ core.a (CommonAnalog.cpp.o) C \ Users \ klsor \ AppData \ Local \ arduino15 \ packages \ SparkFun \ hardware \ apollo3 \ 2.0.2 \ co
res \ arduino \ sdk \ core-implement \ CommonAnalog.cpp first defined here


Any help is appreciated.
Thank.
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]