Size incorrect after uploading boards

Questions about the BatchPCB service

Moderators: phalanx, robacarp

Locked
dan.scof
Posts: 2
Joined: Fri Sep 07, 2012 7:37 am

Size incorrect after uploading boards

Post by dan.scof » Fri Sep 07, 2012 12:32 pm

Hello,

I've been working on a board that is 32mm x 32mm. When I upload the board, the images look correct, but somehow the scale seems to be changing. The summary of the board online shows the dimensions as 0.36 x 0.36 (about 1/4 of the actual size).

This seems to be pretty easily reproducible for me. If I start with a new empty board, then:
1) Add a silkscreen box enclosing a 32mm square
2) Add a drill with diameter 4.8mm at position 4mm, 4mm
3) Upload that test file

I see the same issue. The images look correct, but the size shrinks. The site is using the small sizes for the billing cost, too, incidentally.

Has anyone seen something similar or have suggestions on what might be causing it?

jmbw
Posts: 14
Joined: Mon Mar 07, 2011 3:26 pm

Re: Size incorrect after uploading boards

Post by jmbw » Fri Sep 07, 2012 4:08 pm

I'm having similar trouble. I thought it was because I've been using 0-width lines in my .OLN file all this time (because otherwise it bills you for that extra half-line-width sliver all the way around the outside of your board), and the bot's ability to understand that got broken in the upgrade. But even with a 10-mil outline, the bot appears to totally ignore the .OLN file and computes its own dimensions based on the max/min X/Y of any feature on the board.

Yes the prices come out lower but obviously I'm not going to place an order for a board that might come back with all the edges chopped off (and one previously OK design failed DRC when I re-uploaded, possibly as a result of this truncation, but I can't be sure since the DRC thingy suddenly doesn't send email).

Clearly some stuff needs fixing! I assume they're hard at work on it this very second. Right?

John Wilson
D Bit

dan.scof
Posts: 2
Joined: Fri Sep 07, 2012 7:37 am

Re: Size incorrect after uploading boards

Post by dan.scof » Fri Sep 07, 2012 5:17 pm

jmbw wrote:... the bot appears to totally ignore the .OLN file and computes its own dimensions based on the max/min X/Y of any feature on the board.
Looks like you're on to something. If I add a drill hit in the upper right corner, the dimensions get much closer to correct (although still wrong).

Oddly - switching to outline to be a copper trace doesn't seem to help. Oh well, though. I suppose we just get to wait a few days for things to get fixed.

fooj
Posts: 4
Joined: Mon Sep 10, 2012 9:03 am

Re: Size incorrect after uploading boards

Post by fooj » Mon Sep 10, 2012 9:12 am

I am having similar issues with my board.

checksix
Posts: 11
Joined: Fri Nov 14, 2008 12:59 pm

Re: Size incorrect after uploading boards

Post by checksix » Tue Sep 11, 2012 12:43 pm

Same problem. An email to support confirmed that it's a known problem.

mrdudeman
Posts: 18
Joined: Thu Oct 25, 2007 2:36 pm

Re: Size incorrect after uploading boards

Post by mrdudeman » Sat Nov 03, 2012 12:04 pm

Did this ever get fixed? I'm still seeing this problem. My boards are not showing up with the correct sizes at all, which makes me hesitant to order anything.

Locked